×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Voicemail email

Voicemail email

Voicemail email

(OP)

Hey all,

looking for some input.. when receiving a voicemail to email , it includes a link that is supposed to allow users to manage their voicemails in a web browser.
Mine currently shows: http://AMPWEBADDRESS/recordings/index.php?login=50... , which obviously isn't correct , and I can see in the options where to change the physical link , but if I input my Ucx ip address in place of "AMPWEBADDRESS" I just get a page can't be displayed, like it's an invalid path.

Is there something that needs to be enabled to allow this interface?
I've tried various extensions,and directly accessing the ip for the ucx web interface is no problem, but if I add the /recordings path like documented , or use the above link with the correct IP , I get nothing.

Thanks in advance.

RE: Voicemail email

1. Go to the PBX/Tools page. Select the Configuration File Editor. go to the last page and select the vm_email.inc file.

2. Edit the AMPWEBADDRESS in the line 'Visit http://AMPWEBADDRESS/recordings/index.php?login=${VM_MAILBOX} to check your voicemail with a web browser.\n' and change it to whatever address you would like the users to see.

for example: Visit http://192.168.1.200/recordings/index.php?login=${VM_MAILBOX} to check your voicemail with a web browser.\n

I hope this helps! Have a blessed night!

www.ucidirect.com
Stocking Distributor for E-Metrotel

RE: Voicemail email

(OP)
Thanks for the quick response!
I have edited the link but when clicking i dont get the logon screen , just a page cannot be displayed , same with just copy paste the link above and put my ucx ip in... This is across two different sites so , not a network issue , and the ucx web config is accessible at both as well.

RE: Voicemail email

Are you using the link on the same subnet as the ucx ?
on my local lan the http://192.168.11.99/recordings/index.php?login=33... takes me to the login screen.
from a public address you will need to allow access through your router/firewall with a dnat rule mapping the outside address to the internal address

RE: Voicemail email

Two different sites? You will need to use the Public IP address of the router to access this. You will have to set the Port Forwarding on the router for the Remote Access top forward Port 443 to the internal IP address of the UCx. And if the end customer doesn't want you to forward Port 443, you can use an "off used" port such as 9898 and Port Forward that port to Port 443 on the UCx using TCP protocol. You will also need to populate the Public IP address in BOTH the SIP and Nortel settings.

So now your vm_email.inc file would look like this: Visit http://your External IP address/recordings/index.php?login=${VM_MAILBOX} to check your voicemail with a web browser.\n

In your web browser, you would do this," https://<external IP address>:9898/recordings/"

I know this works because I use it! bigsmile

www.ucidirect.com
Stocking Distributor for E-Metrotel

RE: Voicemail email

(OP)
When accessing this link , i am on a computer on the local lan , same subnet
By 2 sites i mean i have the same problem with 2 different ucx systems
This is all i see:


This seems like it should be very straightforward , but for some reason...
Hitting 192.168.100.2 lets me access the ucx no problem.


Thanks again everyone

RE: Voicemail email

OK...Notice your graphic has "Port 443" on it. Is Port 443 of the router forwarded somewhere else for external access to a server or something? That could be what is going on. So, try Port Forwarding of a port, such as 9898 to Internal Port 443 of the UCx. THEN you can use an address like I posted above. https://<external IP address>:9898/recordings/"

I saw an instance where Port 443 was being used by the IT folks for access to a web server on site. Doing the Port Forwarding trick solved the issue.

www.ucidirect.com
Stocking Distributor for E-Metrotel

RE: Voicemail email

Try clearing your browser cache and /or try a different browser

what does ls -l /var/www/html/recordings show from the cmd line?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close