×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

SK98/WINDOWS 10
2

SK98/WINDOWS 10

SK98/WINDOWS 10

(OP)
ANYONE HAVE HANDS ON WIN 10 AND SIDEKICK 98? With the new release in July 29 tho't someone might have been in the testing aspect of the new MS OS. If so, have you tried Sk 98 or any other version of SK with Win 10? The Win 10 reviews indicate it is compatible with software run win 7, 8 & 8.1. Since SK 98 can't run in the normal program files X86 folder but in the root or program folder I am concerned to confirm it will run in Win 10 before opting for the free upgrade.

RE: SK98/WINDOWS 10

(OP)
I just Googled the question will SK98 run on Win 10 and found a positive answer from a SK98 user who installed the Insider Preview edition of Win10 on a virtual machine and then successfully installed SK98 on that Win 10. Here is the link I found.
http://www.waleedhanafi.com/2014/10/sidekick-98-ru...
He was using the Win7 Pro OS which has no problem with SK98 not being 64bit. Apparently our discussions in this forum have been focused mostly (IMO) on the Win7 Home premium I use. That requires installation of SK98 in a folder other than the x86 folder. (works for me fine in the root)

Sounds like good news. I checked the Win 10 upgrade information and it indicates it installs over the Win7 OS keeping all files and settings. It should be a transparent install. ?? AND FREE!

RE: SK98/WINDOWS 10

(OP)
Continuing the information in this thread- to evaluate Win 10 install of SK98 Waleed Hanafi did a virtual machine install of Win 10 prior to checking the installation of SK98. (link to that process in above entry) The link to his process is below.

http://www.waleedhanafi.com/2014/10/evaluating-win...

RE: SK98/WINDOWS 10

Well done Waleed Hanafi and WDane,

This is great news and keeps sidekick going on and on!

Regards to all
Jim

RE: SK98/WINDOWS 10

I have installed the final release of Windows 10. Sidekick 98 is working well except the Toolbar preferences that I set are not retained on computer re-boot

RE: SK98/WINDOWS 10

After installing Windows 10, SideKick98 not only will not preserve Toolbar preferences on a computer re-boot, but SideKick 98 will not open again if it has been opened and closed. A re-boot is required to get Sidekick to open again.

RE: SK98/WINDOWS 10

(OP)
Skyline151 by toolbar functions are you referring to the icon functions (i.e. save, save as, open, close, etc.)?
What version were you using before Windows 10? Where was SK 98 installed on the root or in the Program files folder (not Program files x86 folder)? I am using Win 7 Home Premium with SK 98 installed on the root of C drive. I am wondering if my setup for SK98 is the same or similar to yours? (mine = Win 7 Home Premium, installed SK98 in root of C drive - program files folder has also worked for other SK 98 installations)

Hanafi was using Win 7 Pro not WIN 7 Home Premium. He was able to get SK 98 running smoothly after installation in the program files x86 folder by right clicking on the Sidekick.exe file and selecting "run as administrator." It ran fine.

Hanafi said that SK 98 is a 16bit program and would not work in the x86 folder since that is dedicated to 64bit programs. Win 10 allowed him to use the "run as administrator" feature emulating Win XP. Hanafi said that Win 7 Pro does not have the same 64bit limitations that Win 7 H.P. does.

I wonder if using Win 7 H.P. installed in a non 64bit folder if Win 10 will treat it differently than if installed in the x86 (64bit) folder?

Sorry to have gone on so long. The questions I asked I hope you will answer. They will help my decision regarding installation of Win 10. I have not installed Win 10 since the download installation has yet to be offered. I am told that my machine meets the Win 10 requirements.

I hope these comments might prove helpful regarding your installation of SK 98 in Win 10.

RE: SK98/WINDOWS 10

(OP)
I have just installed Win 10 and SK98 (installed in the C root) is working fine. All my settings are retained even after a restart of Win 10 as well as closing and opening SK98. Win 10 restored my Win 7 look.

RE: SK98/WINDOWS 10

Spurred on by WDane's post above I have now attempted to install Sidekick 98 on a Windows 10 machine ....and it works! One point to note is that it seems to struggle to install with automatic express install with the the "messaging" options, so just use custom install an all will be fine. I installed my sidekick 98 from a CD distributed free with the October 1999 edition of a magazine called PC Advisor (Issue 49). It is great having Sidekick back again - including the world time map feature . It's just like welcoming back an old friend you haven't seen for years. Now all I have to do is find the back-up disc which has my skw data on it!

RE: SK98/WINDOWS 10


Hi,
I can add that on using the free upgrade from Windows 7 to Windows 10, Sidekick 98 was also automatically included (with a new “installed” date in the Control Panel) and works well.
It would be good to say it all went smoothly but an age old problem turned up: Sidekick 98 would stick when I opened it, a problem I never had with Windows 7. As you know from this forum, it is caused by another program. The culprit turned out to be Skype. It was set to open at start-up. Since unticking this/ closing Skype, I´ve had no further problem with Sidekick 98.

RE: SK98/WINDOWS 10

Truesync desktop (same program) works fine after installing in Windows 10 final version. After the computer is shut and resarted, it hangs after entering password and I can't get in. I have disabled Kaspersky and even tried all compatibility settings. Never had a problem in Windows 7. The only way to restart the program seems to be to reinstall again. Any thoughts?

RE: SK98/WINDOWS 10

Hi starfisher

Truesync Desktop is not exactly the same as Sidekick98, but I imagine the same hangups occur. I have found that Microsoft "One Drive" seems to make it hang as it is starting. That is on my Wife's netbook which was recently upgraded to Windows 10 (32bit).
I have NEVER used the password as it is so easily worked around by deleting a file and is an unneccesary extra hurdle before Sidekick starts!
I imagine there is another program that is starting with windows and as each computers setup is fairly individual my advice would be to check out "Task Manager" and exit any programs that are shown up in there and try after each one to start Sidekick. Each time you can't start Sidekick close it from the Task Manager and try stopping another program until you find the one that is causing the problem.

HTH
Jim

Regards Jim
Check the FAQ area of this Forum for answers (If there are any FAQs!) , it could save you a lot of time and effort! Good Luck!

RE: SK98/WINDOWS 10

I have two Win10 systems running Sidekick 98 from Program Files (x86) and it works fine.

RE: SK98/WINDOWS 10

Good to hear it REDtwo,

But it isn't that much trouble to install the program on the root of the C:\ drive. It appears for most people who have installed it so far on Windows7/10 either 32 or 64 bit, that this gives the best results.

But whatever works for you.
Good luck.

RE: SK98/WINDOWS 10

Good to heard your response James33. When you say install in root do you mean C:\Starfish\Sidekick 98\ or something else? By the way, I have a 3rd system that started out as Win8 that I used the Microsoft update path to go to Win10 that never had Sidekick 98 installed. I installed it last night using Henry W's download and instructions, thread 807-1702833. I added the shortcut to the start menu in programdata. When I booted, I received an error that showed city info and a bunch of special characters and it bombed out. I started it by running the shortcut as "run as administrator" and it worked fine. I then updated the shortcut in the start menu and turned on the "run as administrator" option re-booted and received the same the same error message.

I am puzzled as to why starting the shortcut manually worked and the start menu version didn't. I wonder if there is a difference in how it has to be specified? I really need it to work correctly in the start menu part because a lot of other applications use low core and if I go thru a full re-boot and then have to start it manually, a lot of times it want start because low core is full. The the only way around is to kill apps until it works and re-start them which is time consuming.

This is the error message:

RE: SK98/WINDOWS 10

Dear REDtwo

Actually I have just remembered (I have so many other things to do at the moment that I can forget sometimes) that the cityinfo.dat error arises when you have not installed the program from the Admin account (if there is only one user you are the admin). In fact you need to run the install from that account and specify that you are installing for all users (I think you might be offered that option) and avoid the email option when the program first opens, I used to use it with Eudora before it became open source but haven't found it worked after that.
But, and I cannot stress this enough, install in the root of the C:\ Drive as in C:\Starfish\Sidekick98 or in the case of Sidekick97 (Internet Sidekick) C:\Starfish\InternetSidekick

It has just occurred to me that I remember in DOS there was/is a problem with Paths to Executable files when they contain gaps. As a lot of legacy code in Sidekick dates back to DOS times.... Who knows. Be interesting for someone to have a look at that situation.
I have no time this year, my Art practice and my Thesis both of which I am doing for my BA(Hons) in Fine Art which finishes next June are causing me great 'pain' at the moment. Actually, the Thesis is due to be in by the first week of 2016 so I am panicking. It will get done, but I am sure I am not alone I imagine many other people have felt similarly at this stage! upsidedown

RE: SK98/WINDOWS 10

James33,

Thanks for your update. I re-installed again, 3rd time, and now everything seems to work ok. I did not install in root I installed in Program Files. I have re-booted a couple of times and the problem has gone away, thank goodness! The problem when you use cmd is handling spaces. If you surround the argument with "....." the spaces are recognized.

Good luck with your thesis. I was fortunate in that when I was working on my masters I was given the choice of an extra class or thesis. I, of course, selected the extra class.

RE: SK98/WINDOWS 10

(OP)
I just did the upgrade from Win7 to Win10 after being notified my Dell Inspiron met the Win10 criteria. The upgrade worked flawlessly. I have checked most of my regularly used programs and they run fine.

RE: SK98/WINDOWS 10

I upgraded to Win 10 from Win 7. Sidekick 98 was working OK on Win 7 and the upgrade to 10 seemed to have gone very smoothly.
Sidekick opened, closed and all operated correctly possibly more smoothly than on Win 7.
However... I now note that the Memos function won't save any new data I enter here. The program can also crash when I try and save in the Memos screen.
Any thoughts.

RE: SK98/WINDOWS 10

Hi Storrar,
Could be you have a read only file.
Backup your Userdata (especially Numbers.SKWrite)
Try changing the name of the card file with Save Memo File As TEST.
Do your edits.
Save.
If this works rename TEST.

RE: SK98/WINDOWS 10

Well, I thought I'd put in my 2¢. I was panicked by the thought of losing my SideKick when Win10 began importuning me to update. But, one day, my spouse who has a computer of similar vintage to mine, also running Win7 Home Premium, decided to click on the Win10 upgrade (without bothering to consult her "technical advisor"). So, after dithering for a few more months, I decided to try installing SK98 on her computer. I used the instructions for installing from "floppy disks" (they're still available at: https://dl.dropbox.com/u/9039305/Sidekick98.zip) given by HenryW in another thread (http://www.tek-tips.com/viewthread.cfm?qid=1702833). I installed in root, i.e. c:\Starfish\Sidekick98, after having first changed the properties of the installer to be compatible with WinXP and also telling the system to run as admin. So that worked like a charm. I copied all my data folders over and was good to go...on my spouse's computer.

When I finally pulled the trigger on "upgrading" my computer to Win10, things pretty much went without a hitch. Low and behold, my previous installation of Sidekick98 on my Win7 computer was still fully functional on the new Win10 installation. I didn't have to do anything! Yay!

FWIW, my techie brother-in-law laughed at me two weeks ago when I mentioned I was still using SideKick. He thought SK had disappeared with the death of DOS. But what does he know? He also thought there was no need for one to find an iOS app that simulated one of those most excellent RPN scientific calculators HP used to make.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close