×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Search Hangs

Search Hangs

Search Hangs

(OP)
Hello all,

We are currently using Exchange version 14.3 (Build 123.4).

It seems that every day when I come in users are complaining that search is not working in Outlook (confirmed on my machine). Users are using a variety of Outlook versions, but most are on 2010 or 2013. None of them are using it in cached mode.

I'm not sure what is actually getting it going again, but I've been trying the following:

Restarting the following services: "Microsoft Search (Exchange)", and "Microsoft Exchange Active Directory Topology" (plus all the services that require them). Between the two it seems to cover a fair amount of the exchange services.

The first day searches started working sometime shortly after I did that. All the others, I ended up doing ".\ResetSearchIndex.ps1 -force -all" from the shell. Granted it can take some time after resetting the index for it to build up again and work - if that is even fixing it at all. Perhaps just the time it is taking me to do those tasks is fixing the problem.

Any idea what might be going on?

Thanks!

RE: Search Hangs

(OP)

CODE

Test-ExchangeSearch -Identity <username> 
Running the above code reveals the following:
Database          Server                      Mailbox        ResultFound   SearchTime   Error
                                                                                                              InSeconds
----------------     -----------------------   ---------------    -----------------   ----------------   --------
Mailbox D...    SERVERNAME   UserName      False                 -1                    Time out for test thread. 

While it was running I noticed an exception: "Unable to SetSear" before it got cut off from the side of the window.

RE: Search Hangs

I'd say that you need to update the search.
Update Exchange to the current service pack and rollup.
Update the search filter packs to the current version.
Then for each database delete and recreate the search catalog on the active copy of the database then update the passive with a -catalogonly to update their search indexes too.

RE: Search Hangs

(OP)
Thanks Zelandakh!

I'm currently in the process of installing Rollup 9 (though 8 was already installed - I found that build information above to be inaccurate, apparently a known problem but supposedly not a bug).

I haven't heard about the search filter packs before - what is this?

Based on a conversation I had with someone else, ResetSearchIndex supposedly does delete the search catalog and rebuild it (i don't know about the -catalogonly option). Is the delete and recreate something different?

RE: Search Hangs

(OP)
Thanks for those links and information!

Turns out we already have "Service Pack 2 for Microsoft Office 2010 Filter Pack (KB2687447) 64-Bit Edition" installed.

I have apparently tried the catalogonly command before (just didn't recognize it). I get an error: Database "Mailbox Database\servername" has only one copy. This task is supported only for databases that have more than one copy."

RE: Search Hangs

(OP)
We ended up contacting a 3rd party to help with our problem as my research was getting nowhere (before Zelandakh had posted the first response).

The technician started off retrying everything that was mentioned in the question, and the running a few additional counters/checks.

The technician suggested we install Rollup 9 (the latest). I did this on Saturday. On Monday, the search wasn't giving errors like the original problem, but it wasn't giving proper results either. So I ran ResetSearchIndex.ps1 again to rebuild the search index.

Ever since the index was rebuilt, it has been running fine (3 days now), where the problem used to happen daily. Looks like Rollup 9 fixed whatever issue we were having.

Thanks Zelandakh, looks like you and the other tech both came up with the solution.

RE: Search Hangs

I would expect resetting the index did it as there isn't anything in ru9 about search.

You may find something in the app logs about an issue but either way you got it resolved.

RE: Search Hangs

(OP)
I KNOW that just resetting the index didn't do it - as it had been tried twice prior to the rollup.

Perhaps ru9 didn't really have anything about search, but whatever occurred during the installation of it DID help.

RE: Search Hangs

Agreed - great to get confirmation back from you that all is good.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close