×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

DB Cleanup task not running

DB Cleanup task not running

DB Cleanup task not running

(OP)
I have a cleanup task for cleaning out old backups. It hasn't been running. Well, it's been starting, but failing every time.

The log file says: "Executed as user: SEYBOLD\SQLAGENT. Microsoft (R) SQL Server Execute Package Utility Version 10.50.2500.0 for 64-bit Copyright (C) Microsoft Corporation 2010. All rights reserved. Started: 3:00:00 AM Progress: 2015-02-19 03:00:04.67 Source: {1B09CDD3-A5E1-4C82-AEC6-4E36DD2BA8DC} Executing query "DECLARE @Guid UNIQUEIDENTIFIER EXECUTE msdb..sp...".: 100% complete End Progress DTExec: The package execution returned DTSER_FAILURE (1). Started: 3:00:00 AM Finished: 3:00:05 AM Elapsed: 4.594 seconds. The package execution failed. The step failed."

When I look at the task, I notice a red x on it that says "No connection manager specified" or " There were errors during task validation." I can only assume this is the reason.

My other ones are fine.

Someone suggested this to me "Have you opened the DTSX package to see what is in there for a connection. It sounds like nothing is in there for whatever reason. "

To which, I answered "I don't know what that is. But, I did open the properties and Connection is blank. All the others say "Local Server Connection".

I wonder if I need to be on the server to make changes. I usually manage things from my own PC. In the past I thought I only had to go to the server to create new plans, not change existing ones. And I think this one was working fine until I changed the "Delete files older than" setting. "

I'd love some help on this.

RE: DB Cleanup task not running

(OP)
Well, no one said anything. I fixed it myself. I am still not totally sure why this happened; maybe someone can shed some light on that. But, I open up the step and the Connection part was blank. I entered in all the credentials and changed the schedule to now to test and my files cleaned up.

Too bad no one here helped me so I could have fixed it sooner.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close