Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Upgrade 2960S fails

Upgrade 2960S fails

Upgrade 2960S fails

I'm using CNA 6.1.0 to upgrade all our 2960S switches but about 5-6 fail. The same process using the same file has succeeded on 10-12 other 2960S without issue.

It attempts to upload the file then gives the error:


Failed to execute the command archive download-sw /overwrite /http iosFile
I need to reload the switch before I can attempt an upgrade again but subsequent upgrades also fail with the same issue.

Google isn't terribly helpful. Any ideas why this occurs and how to resolve it?

This is trying to upgrade from 15.0(1)SE3 to 15.0(2)SE6 for most but in one case it's 12.2(54)SG1 to 15.0(2)SE6.

RE: Upgrade 2960S fails

I found this http://jhigham.blogspot.com.au/2013/04/update-cisc... and it helped. After deleting a folder of the current version I still was not able to use CNA to upgrade but using the CLI to upgrade worked.

I'd still like to know why it won't upgrade via CNA. Any ideas?

RE: Upgrade 2960S fails

Use the CLI and a FTP or TFTP server?

RE: Upgrade 2960S fails

As per my previous post

Quote (disturbedone)

but using the CLI to upgrade worked.
I did the upgrade via CLI & FTP but my question is why does it fail via CNA (yet work via CLI) and what needs to be done to get it to work via CNA? It's easy to upgrade 25 switches via CNA as it's only a couple of clicks whereas to do everyone via CLI takes an hour of manual work.

RE: Upgrade 2960S fails


archive download-sw /overwrite /http iosFile 
If that's the actual CLI command CNA is trying to send to the switchen its obviously wrong as there should be a URL after the /http part - i.e. '/'.
I have only used CNA a few times and wasn't too impressed with it, however I was trying to use it to monitor the switches and not upgrade them. I can see the advantage if you want to upgrade several..


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close