Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

ERROR 1 during run in with gfortran

ERROR 1 during run in with gfortran

ERROR 1 during run in with gfortran

I try to solve an algebric system A*T=b by by calling the LAPACK and BLAS libarairies. the subroutine used is SGTSV with a 899 by 899 matrix.
compilation is well done, i used this syntax:

CODE --> fortran

ipsa@ipsa-HP-Compaq-8510p:~/Documents/codes eq chaleur/res eq ch variable/res_var_lib/test2$ gfortran -std=legacy -fcheck=all -Wall -g -fbacktrace -Wtabs test2.f90 -o test2.exe /usr/lib/liblapack.a /usr/lib/libblas.a 
. But, the the run display an error with this syntax:

CODE --> fortran

tou@tou-HP-Compaq-8510p:~/Documents/codes eq chaleur/res eq ch variable/res_var_lib/test2$  ./test2.exe
 ERROR           1 

I didn't understand the origin of this error!!
i run with debugging:

CODE --> fortran

tou@tou-HP-Compaq-8510p:~/Documents/codes eq chaleur/res eq ch variable/res_var_lib/test2$ gdb ./test2.exe 
this operation takes much time!!! what should i do? some suggestions,

RE: ERROR 1 during run in with gfortran

Can you add a


print *, 'starting' 
at the start of execution, build and run the program. Does it print starting followed by Error 1 or Error 1?

If it prints starting followed by Error 1, then you can narrow down where the problem is occurring by adding a few more print statements, if you do not wish to wait for the debugger to load. If it starts printing error 1 (ERROR_INVALID_FUNCTION) it could possibly be your code calling a routine that is not supported.

Instead of an 899 by 899 matrix have you tried something simple like a 3 by 3 matrix to see whether everything is being called correctly? If it is ok on a 3x3 but not on an 899x899, it could possibly be a space problem. Are all the arrays the correct size? Not a problem if you used something like integer, parameter but it may be problem if all the sizes are hard coded.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close