Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

I installed MySQL 5.75 on OSX 10.10 and it is up and running successfully; but, following execution of mysql_install_db I can not locate .mysql_secret anywhere... I double checked the home env variable to make sure as well as searched via spotlight etc... It simpley does not seem to exist; but, the data directory WAS created successfully...



-Allen M.

RE: Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

Open up terminal.

Type this


sudo find / -n ".mysql_secret" 

Enter your password at the prompt and after a while it should give you the path to the file.

Different installation mechanisms may not use the random-password flag. So you might also try that old fruit of root:root as user:pwd on local installs.

RE: Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

Thanks for sudo find suggestion...

Found it at /private/var/root/.mysql_secret but password isn't being accepted for user 'root'@'localhost' (using password: YES)

Re ran mysql_install_db to re-create the data dir and a new random password and it still isn't being accepted...

Not sure what now- restarted daemon and still not accepting root password created in .mysql_secret

Open to ideas...

RE: Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

that is most odd as the installation would normally be run as your user and not as root (which is not typically an enabled account on macs)

there are four solutions that come to mind.


mysql --host= --user=root -p 
hopefully that should accept the password in the secret file. the difference here is that you are specifying a tcp connection whereas using the localhost keyword causes the client to default to a socket. if there is any possibility of two versions of mysql installed then this could cause confusion.

incidentally running this command


which mysql 
could help diagnose this if you see the mysql being located in an unforeseen folder.

the second solution is to rerun the install_db script and suppress the password generation. to do this add the --insecure option to the install statement. or specify where the random password should be written



the third is to reset the password


sudo su
killall mysqld
mysqld --skip-grant-tables --skip-networking
//from the mysql prompt
UPDATE mysql.user SET Password=PASSWORD('MyNewPass') WHERE User='root';
//from the terminal
killall mysqld 

then restart mysql in the way you normally would (without the security bypasses).

4. uninstall mysql and reinstall it through MAMP. I've been using MAMP for years and not once has it given me any strife.

RE: Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

mysqld --skip-grant-tables --skip-networking doesn't seem to work with MySQL 5.75 and doubt it's available w- MAMP. Will probably try to re-install. I need 5.75 for the new GIS functions...

RE: Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

skip grant tables is available: http://dev.mysql.com/doc/refman/5.7/en/server-opti...

the version of mamp i have is 5.5.34. i see no difficulty in upgrading that to whatever arbitrary version.

RE: Issue w- MySQL 5.75 on OSX 10.10 - can't find .mysql_secret

reinstalling it fixed it... but for successful install you must un-check the create startup item option with OSX 10.10

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close