×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Warning - Multiple default gateways

Warning - Multiple default gateways

Warning - Multiple default gateways

(OP)
Hello,

I have a windows 2008 r2 configured as a web server with two nicks.

one talks to the local area network. we are connected to our corporate office via sonic wall vpn

the second nic has an external ip address for the web server.

this has been working well for years, all of the sudden I started to get the "Warning - Multiple default gateways" error

the configuration has not changed.

if I dissable the nic with the external ip I can ping the corporate office where the main db lives if I enable the nic with the external connection, then the connection to the vpn goes down

not sure how to solve this one

my local ip

ip 192.1.1.19
gateway 192.1.1.1 this is the sonic wall ip address as well

external is 2xx.xxx.xxx.x7
gateway is 2xx.xxx.xxx.x5


any idea on this one?

thanks!!

RE: Warning - Multiple default gateways

Windows can't have multiple default gateways active at the same time.
Remove the default gateway from the Internal NIC, leaving the default gateway on the External NIC. Then add static routes (or static summary routes) to your internal networks via the old default gateway on the Internal NIC.

CODE

route add -p 10.0.0.0 mask 255.0.0.0 192.1.1.1 
This is assuming your internal networks are made up of RFC1918 10.0.0.0/8 addresses - which it looks like they aren't however you don't state what they are. The '-p' makes the route permanent so it will survive a reboot of the server (the routes are actually added to the registry).

Andy

RE: Warning - Multiple default gateways

(OP)
Andy,

thank you for your reply, but here is what I get confused

my internal address is 192.1.1.19

I can ping any address like 192.1.1.5 and I do get a reply

If I ping 192.168.5.5 our vpn connection I get noting

if I turn off the external nic and ping 192.168.5.5 I get a reply back

is this coming from the network cards? or a rule in my sonicwall?

RE: Warning - Multiple default gateways

(OP)
update, i gave the internal nic a dynamic ip address and I can ping my vpn, but if i assign the ip id does not like it have no ide why

RE: Warning - Multiple default gateways

Its basic routing with multi-homed hosts. Drop to a command prompt and look at the output of 'route print' you will see you have two default gateways but I am guessing the External NIC is top of the list. Pinging directly connected hosts (i.e. 192.1.1.0/24 will work fine, however any 'off net' traffic will go via the External NICs default gateway. Follow my instructions but change the static route to be 192.168.0.0/16

CODE

route add 192.168.0.0 mask 255.255.0.0 192.1.1.1 
Andy

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close