×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

(OP)
Hi all,
we are having a problem with accessing Nice Perform 3.5 web pages using 32bit Win 7 PC with Internet Explorer 10, .Net Framework 4.5.1. Nice web page keeps promting to run the setsecurity.exe tool. We used to solve this by adding the registry key EnableIEHosting (DWORD 32bit, value 1) to the related PC (HKLM/SOFTWARE/MICROSOFT/.NETFramework ). It always worked for IE8 but now for IE 10 it doesn't.

Don't you have an idea please?
Regards
Bbednar

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

I would try removing the .net 4.5 framework. If it works then if windows updates reinstalls it it will break again. Im wondering if its the same as the Inform 3-4 issue with .net 4.x.

Juan Rivera
Senior Telecomm. Technician
Micro Strategies, Inc
www.microstrat.com

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

dont forget to reboot.

Juan Rivera
Senior Telecomm. Technician
Micro Strategies, Inc
www.microstrat.com

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

Have you put the key in the right registry area? It is different for 32 and 64 bit environments

• 32-bit: HKLM\SOFTWARE\MICROSOFT\.NETFramework
• 64-bit: HKLM\SOFTWARE\Wow6432Node\Microsoft\.NETFramework

Some days I do my job, other days it feels like I'm doing everyone elses job, other days I should have stayed at home and mowed the lawns.

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

(OP)
Thank you for your posts. But still no progress - I can not uninstall the .Net 4.5.1 - we need to make it working just with the latest .Net as possible. I tried to install .Net 4.5.2 with no success. Yes, I am using correct registry path for the key - HKLM\SOFTWARE\MICROSOFT\.NETFramework
- for the 32 bit Windows 7 which I have.

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

Is this a new site that you haven't previously had working or is this an old site that you've added 4.5.1 to?

Some days I do my job, other days it feels like I'm doing everyone elses job, other days I should have stayed at home and mowed the lawns.

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

Continuous Set Security loop
.net 4.5.1 was installed on all of their PCs.

To fix this problem, the EnableIEHosting value of the registry subkey HKLM/SOFTWARE/MICROSOFT/.NETFramework must be set to 1.

For more details please read the Microsoft article Application Compatibility in the .NET Framework 4.5. To work around the problem:

PLEASE NOTE: Even after uninstalling the update to .net 4.5.1 that you will still need to perform the following steps.

1. Click Start>Search, and in the search field, type Regedit.
2. Right-click the Regedit icon and select Run as Administrator from the menu.
3. Enter the correct user credentials for working with registries.
4. Follow the link mentioned above to find the required registry folder. NOTE: The registry path is different for 32-bit and 64-bit Windows operating systems: ? 32-bit: HKLM\SOFTWARE\MICROSOFT\.NETFramework ? 64-bit: HKLM\SOFTWARE\Wow6432Node\Microsoft\.NETFramework
5. Right-click in the registry folder and select New>DWORD (32-bit) Value to create a new DWORD value key. NICE Interaction Management Release 4.1, NICE Perform, NICE Perform eXpress & NiceLog System 8.9 94 Chapter 5: Microsoft .NET Framework Microsoft .NET Framework 4.5 with NICE Perform 3.2/3.5 and NICE Interaction Management 4.1 Third-Party Technical Guidelines (Rev. B5)
6. Rename the new key as follows: EnableIEHosting
7. Right-click the EnableIEHosting key and select Modify from the menu.
8. In the Edit DWORD (32-bit) Value window that appears, type 1 in the Value data field and click OK.


RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

(OP)
Hello all,
thank you for the ideas.

To noriknick - that is just the howto which I already know and used many times on PCs with the installed .Net Framework 4.5.1 BUT the problem is that if on the PC with .Net Framework 4.5.1 you upgrade Internet Explorer from 8 to 10 it STOPs working. Do you have the Nice Perform working on a PC with IE 10?

To Almostme - it is an old site, old PCs where it all worked. But it all stops working when you upgrade IE from ver 8 to 10.

So stilll no progress for me.

Regards
Bbednar

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

Have you set IE to compatability mode?

Some days I do my job, other days it feels like I'm doing everyone elses job, other days I should have stayed at home and mowed the lawns.

RE: EnableIEHosting not working (Nice Perform 3.5, client with IE10, .Net 4.5.1) - can't access Nice

I think it has to do with .net 4.5.1 been installed...and not been able to function with IE browser.

I have windows 8.1 which by default comes loaded with .net 4.5.1, and also experience the set security loop. Also cannot uninstall as part of the OS. Compatibility settings on IE 11 browser doesn't even allow it to function.

used another machine with windows 7 , IE browser 11, .net 4.0 and no issues connecting.

So i believe .net 4.5.1 is the issue here....and there is NO way of uninstalling it unfortunately.
Maybe NICE fixes the setsecurity to allow 4.5.1

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close