Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Cisco/Linksys EA4500 not working at gigabit speed?

Cisco/Linksys EA4500 not working at gigabit speed?

Cisco/Linksys EA4500 not working at gigabit speed?

This is a home router, and we had a severe storm the other day and the router stopped working (temporarily). It must've been a lightning surge--but it didn't destroy the router--it destroyed the power supply. So I got a new power adapter of the same rating and the router booted and everything was fine...sort of.

I noticed that copying files from one machine to another was much slower (both Windows 7 machines, wired with Cat 6). I used to be able to move large files and see Window's file-copy dialog show speeds in the 40-50 MB/second range, which is reasonably good. Now it is consistently around 11 MB/second--basically a 100 Mbps connection. What happened? Can a router step down like that and lose it's gigabit ability while still workable at 100? I would think if the storm hurt it--it's either toast or it's not.

So does anyone have any ideas of what could be happening here? First, here are a few things I tried:
--- I plugged the cables of each PC in question to another known-good Gigabit router and the speeds were immediately back in the 40-50 MB/second range.
--- On the original router, I unplugged all other device cables--I thought maybe I had unknowingly plugged in a pc with a 100 speed card and that may have brought the whole thing down to the 100 Mbps. (I'm not a router expert but I recall years ago hearing that any router will transmit at the lowest-speed device that's plugged into any port)
--- I upgraded to the latest firmware (

Thanks for any help or ideas to try.

RE: Cisco/Linksys EA4500 not working at gigabit speed?

Can you confirm that the ethernet interfaces in question are indeed coming up at 100Mb/s? (ie, in the device's configuration, what does it show for port status? What does it show for port configuration/settings?)

RE: Cisco/Linksys EA4500 not working at gigabit speed?

There are over a dozen config settings, but, for both PC's nics, anything 'power-saving' or 'green' is disabled, the 'disable gigabit' is disabled. There is the Speed & Duplex option--which has always been 'auto negotiate', but just now I forced both to 1.0 Gbps, and still I get the 11 MB/second transfer rate. Clearly there's something within this router that is not set right, I don't think it's the nics--the same to cables I can plug into the router right next to this one and the speed is back at the high end. The only reason I don't keep them plugged to the 'good' router because I'm out of ports and have to unplug two others in order to test this.

Maybe it's not the storm at all--because with the new adapter I decided to move the router, and in doing so shuffled some of the port connections. But...I'm back to testing bare bones--the two pcs alone on one router go full speed, and on the other they're down at 100 Mbps. And Cisco's GUI is so horribly crippled and featureless that I can't find any good info there. I may just flash this with DD-WRT and see if that changes things. I don't know what to do now.

RE: Cisco/Linksys EA4500 not working at gigabit speed?

Ok, here is what I found:

I tried every combination of two ports for the two PC's, and found one that worked.

So, if I use two *specific* ports, I get the full gigabit speed. So it appears that two of the 4 (not including WAN) ports are bad--they will only transmit at 100 Mbps. The other two do the full gigabit.

So I guess it's time for a new router.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close