×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

AIX /VIO error ---Kernel extension sdduserke was not loaded

AIX /VIO error ---Kernel extension sdduserke was not loaded

AIX /VIO error ---Kernel extension sdduserke was not loaded

(OP)
Hello,

On my primary VIO , whenever I run pcmpath commands I am getting this error

# pcmpath query adapter

Kernel extension sdduserke was not loaded. Errno=8.
Please verify SDDPCM device configuration

I have following versions of VIO and sddpcm
# lslpp -l |grep -i sdd
devices.sddpcm.53.rte 2.4.0.3 COMMITTED IBM SDD PCM for AIX V53
devices.sddpcm.53.rte 2.4.0.3 COMMITTED IBM SDD PCM for AIX V53

1.5.2.1-FP-11.1

Guys any idea why I am getting this error And all my disks coming from SAN are in defined state .SAN team said all is good from their end .

RE: AIX /VIO error ---Kernel extension sdduserke was not loaded

Hi
The SDDpcm kernel extension is not loaded because no compatible devices were detected or configured. This is normal for a system with SDDpcm installed that has no associated devices. The extension is not loaded because there is no need, there is nothing for it to do so it does not load.

The reason is "And all my disks coming from SAN are in defined state", which means your VIOS knows about some disks but cannot contact them anymore.

Is your VIO still connected to the SAN?

VIO 1.5 is way out of support, as is 2.1 but updating probably won't help with a problem like this.

Is it a dual VIO configuration and can the other still see the disks?

The command fcstat should show the connection state of the fibre interfaces.

"SAN team said all is good from their end" - Do you mean the SAN team, can your SAN switch support team confirm your host is logged in to the SAN and your target storage ports are logged in, and the zoning is correct? Or do you mean the SAN "Storage Subsystem" team say all is OK because they can see your host ports logged into their storage over the SAN?

HTH

RE: AIX /VIO error ---Kernel extension sdduserke was not loaded

(OP)
DukeSSD Thanks so much for detail reply , Here are the answers to you questions

ON 06-06-2014 , all path got failed
AB3DC007 0606065014 P H hdisk23 OPEN PATH FAILED
AB3DC007 0606064914 P H hdisk23 OPEN PATH FAILED
AB3DC007 0606064914 P H hdisk23 OPEN PATH FAILED
AB3DC007 0606064814 P H hdisk23 OPEN PATH FAILED
AB3DC007 0606064614 P H hdisk22 OPEN PATH FAILED
AB3DC007 0606064514 P H hdisk22 OPEN PATH FAILED

************************
The SAN team dont see the Fibre Cards , the cable guy tested both cables , SAN's switch ports and they are good .They pointed that Fibre cards might be bad but I ran diag on the Fibre cards and it says tested good .
************************
Its a dual VIO setup , all paths coming from VIO1 are failed but all paths coming from VIO2 are working fine and LPARS are up
************************
I ran fscstat on the card here is the output, I get error in the last line

# fcstat fcs0

FIBRE CHANNEL STATISTICS REPORT: fcs0

Device Type: FC Adapter (df1000fd)
Serial Number: 1B70404BA8
Option ROM Version: 02C82138
Firmware Version: B1F2.10X8
World Wide Node Name: 0x20000000C960711E
World Wide Port Name: 0x10000000C960711E

FC-4 TYPES:
Supported: 0x0000012000000000000000000000000000000000000000000000000000000000
Active: 0x0000010000000000000000000000000000000000000000000000000000000000
Class of Service: 3
Port Speed (supported): 4 GBIT
Error opening device: /dev/fscsi0
errno: 00000046

*************
SAN team dont see the Fibre cards , They are saying to replace the FCs but I dont see any errors on the server except this one which I got after the reboot

B8113DD1 0710172914 T H fcs1 LINK ERROR

and here is the last error part of the above error

Standard input
Descriptionput
LINK ERRORnput
Standard input
Probable Causes
BUSYdard input
ADAPTER HARDWARE OR CABLE
DEVICErd input
FIBRE CHANNEL SWITCH OR FC-AL HUB
Standard input
Failure Causes
CABLES AND CONNECTIONS
DEVICErd input
FC-AL HUBinput
FIBRE CHANNEL SWITCH
Standard input
Recommended Actions
NO FURTHER ACTION REQUIRED UNLESS PROBLEM PERSISTS
CHECK CABLES AND THEIR CONNECTIONS


Thanks so much for your help .

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close