×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Exchange cross forest migration - 2003 to 2010

Exchange cross forest migration - 2003 to 2010

Exchange cross forest migration - 2003 to 2010

(OP)
I'm trying to pull some mailboxes from our sister company's Ex2003 server to our Ex2010 system. Checked loads of MS sites and blogs and seems like I'm doing it the right way but it just doesn't work for me. Any advice gratefully received.

From Ex2010 system using EMS:
- LocalCredentials = Get-Credential
- RemoteCredentials = Get-Credential
- Set-AdServerSettings -ViewEntireForest $True
- Prepare-MoveRequest.Ps1 -Identity "CN=User,OU=Container,DC=Source,DC=Com" -RemoteForestDomainController DC1.Source.Com -RemoteForestCredential $RemoteCredentials -LocalForestDomainController DC1-Destination.Com -LocalForestCredential $LocalCredentials -UseLocalObject

------all the above works, I get 1 Mailbox Ready to Move & a disabled user created in the Destination.Com domain.----------

- New-MoveRequest -Identity "CN=User,OU=Container,DC=Source,DC=Com" -RemoteLegacy -TargetDatabase "EX-DB" -RemoteGlobalCatalog "DC1.Source.Com" -RemoteCredential $RemoteCredentials -TargetDeliveryDomain "Destination.Com"

-----this gives the output as per below-------------------

You must specify the RemoteTargetDatabase parameter.
+ CategoryInfo : InvalidArgument: (property.sbg.la...ded)/migrateian:MailboxOrMailUserIdParameter) [New-MoveRequest], RecipientTaskException
+ FullyQualifiedErrorId : BCFB1F12,Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest

----but the RemoteTargetDatabase command is only used it you are pushing a mailbox to somewhere not pulling, I think----------

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close