Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

CVSNT update, checkout issue

CVSNT update, checkout issue

CVSNT update, checkout issue

We have used CVSNT in our group without issue for years. Our installation of CVSNT is running on Windows Server 2003 Enterprise Edition. We are using CVSNT 2.0.51d and CVS locking service 2.5.05.

Unfortunately, we began to encounter issues with CVS yesterday. It looks like CVS has an issue that leads to a problem with the CVS locking service. We get the following error when we try to check out a module, list history for a file, perform a CVS update, etc. In this example, we see the following error when we do a checkout:

Failed to obtain lock on /cvs/MyProject/.myFilename,v: FAIL Unknown flag 'Full'

We have five CVS modules. We see this error when we try to check out any of the five modules. We didn't do anything unusual lately either. We did create a CVS branch in one of our modules yesterday as well as our typical commits, but we've created branches before and have completed thousands of checkins.

The CVS ls command does not fail. Other simple commands do not fail either. My guess is there's an issue with the locks. We did try running the CVS lock service in debug mode (cvslock -test) but we did not see any unusual debug messages when we used our CVS client to connect.

We also currently use the pserver method to connect to our CVS server. When I login to our Windows server - where the CVS server resides - and run a CVS client locally on that server and connect using the local method, the CVS checkout works fine!

Can anyone provide any ideas to help us resolve this issue? I know that another user posted a similar question a while back:


RE: CVSNT update, checkout issue

I'm experiencing the same error. did you ever resolve it and if so, how?


RE: CVSNT update, checkout issue

Unfortunately, I had to reinstall CVSNT and that solved the issue.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close