×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Avaya - Midsize Business Template (CM 5.2)
3

Avaya - Midsize Business Template (CM 5.2)

Avaya - Midsize Business Template (CM 5.2)

(OP)
Hi all,

I'm trying to get a lab setup for individual study (am currently a Nortel tech making the jump to RED) and found out that Avaya had this Midsize Business Template out on Release 5.2.1 which could actually emulate a G650 Gateway as well as the CM, SES etc.

Am just wondering, has anybody managed to install this on a VM solution like VirtualBox or VMware Workstation or any other similar solution for that matter..just to get it working..?

I've managed to get the right System Platform installed using Oracle's Virtual Box but i'm having some problems when trying to install the template itself due to what i think was a spec error (something about "Volume group "VolGroup00" not found" )..would this be to the fact that I set the HDD size on the VM to dynamic incrementation rather than allocating the full lot from the get-go?

I've also been searching for the proper server specs for this template on support.avaya.com like crazy but couldn't get them down exactly. I've a very powerful laptop and was hoping I could achieve this.

Any advice/hints are very much appreciated.

Regards,
Tudor

RE: Avaya - Midsize Business Template (CM 5.2)

Yes, and in VMWare ESXI 5.1 worked for me.

Bonus points if you set up a CM6 virtual machine and install your System Platform for MBT 5.2.1 in VMWare and IP address your CM 5.2 the same as CM6. Then you get your G650 in MBT 5.2 on a CM6 system.

Or buy a G350 for 100 bucks :)

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Hi Kyle,

You're a star man! :) Sneaky tip with the CM6 ! That's the coolest idea I've heard lately!

I'll get cracking on this one; trying to figure out the best way to go to install ESXi in my laptop (I've a Sandy-Bridge i7 and 16 GB of DDR3 with a 2 TB HDD)..wouldn't want to erase my Win partition (feelin' lazy, I know).


Here's a star for your efforts!
Cheers!
Tudor

RE: Avaya - Midsize Business Template (CM 5.2)

This is interesting. How are you guys dealing with the licensing parts of the installation? I've been playing around trying to get something working with CM 6.3 with the VMware template, but can't get anything working after install because the licensing is missing.

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Hi phonebits,

I haven't managed to get this one down just yet. The MBT 5.2.1 runs CM 5.2 & I've been told you can get a 30-day grace period on the licensing after which you just reinstall the thing . Of course this is just for training/education purposes :) so yeah...

I'm fairly new to the RED stuff but did manage to load an S8300D CM 6.2 Embedded Simplex server in a G450 and it ran for 30 days, it would take config changes but if you restart it then all the configs are nulled out..not sure how this will translate into the VM realm though...would be very interesting to see but am taking it one baby step at a time atm :)

I can't get any pings out from the console domain VM (ESXi hosted) to my PC's IP even though i can ping dom0 from it. I spec-ed the ESXi with 4 NICs (following the Avaya install doc) and did the same for the nested VM hosting System Platform...I think I should have done one NIC for the ESXi and 4 for the SP one though but it's awful late where I'm at now so will bang at this again the coming day.

I'll post back with the specs / details that worked (that is if i get it working).

Cheers all!

RE: Avaya - Midsize Business Template (CM 5.2)

I'm a CS1000 guy as well, dabbling in the RED world. I have an old Definity running CM2.1 that I've been doing some playing around with. The MBT sounds really promising. I have the media for System Platform 6.0.3, but can't seem to find the MBT template file. I'll keep hunting I suppose. I look forward to hearing what others manage to get working.

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
I know what you mean :) the reason why I'm trying the MBT 5.2.1 is that it has "Media Services" capabilities which means it emulates a full G650 gateway and cards..so you can have physical IP phones running without a physical gateway :) => the ideal practice lab. Releases 6.x of the "Avaya Aura Solution for Midsize Enterprises" have removed this and would have you buy a physical gateway instead. Have you access to the Avaya PLDS site? If so, download the following:

- MBT00000073 (System Platform 6.0.3.0.3 iso image (vsp-6.0.3.0.3.iso))
- MBT00000070 (MBT_5.2.1.1.10_with_media_services.iso)

If not, let me know & I'll try to help you get these; I still haven't broke any grounds with this yet due to time constraints but hopefully I'll have something in the next 48 h.

Kind regards,

Tudor

RE: Avaya - Midsize Business Template (CM 5.2)

No PLDS access unfortunately. I have the System Platform image handy, but the template is much harder to locate. If you have any way I could get ahold of it that would be great. If I get anything working or find the trick to getting it going I'll be more than glad to share.

Thanks
Anthony

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Hey Anthony,

Am uploading the MBT template with media services at the moment. It's 8 packed as 8 x ZIP files. Once they're all up, I'll post the links. Am using 4shared for this so you might need to create a free account on their site (I'm also skeptical about registering to sharing sites but, alas, i know this one works). If you have a FTP server I can upload the ISO file directly there?

Will keep you posted.

Cheers!

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Hi guys,

Well :) this works !!! Finally !

My setup: Clevo P150EM with Intel I7 3610 CPU, 16 GB of RAM, WD MyPassport 2TB drive for Virtual Machines.

1) installed VMware Workstation 10 on Win 7
2) installed VMware ESXi 5.1 as a "nested VM" in Workstation (i know :))
-> assigned 3 CPUs (2 cores per CPU) for a total of 6
-> assigned 12 GB of RAM
-> assigned 600 GB of HDD space (thin provisioning)
3) used vSphere to create a new VM on the ESXi for the System Platform server that is hosting the Avaya Template
-> assigned 4 cores
-> assigned 10 GB of RAM
-> assigned 550 GB of HDD space
-> assigned 4 x NICs all "bridged" back to the ESXi NIC which was bridged to my physical NIC on the laptop

a) installed SPlatform from the above ISO (make sure you have an active DNS server that resolves the Domain-0 and udom entities; i heard the install can fail if not)
b) had a problem after the install because i couldn't ping anything (ex. my PC) from udom (console domain) except Domain-0
-> fixed this finally by opening up a cmd prompt on my PC and adding a static route to the udom IP using the Domain-0 IP as the gateway (this actually worked! :) )
-> this one was the hardest part to nail down...i did about 6 reinstalls until i had it sorted this way
c) installed wamp server on my PC; extracted the MBT ISO in the www folder that wamp creates
-> deleted the index.php file in the www root
-> edited the httpd wamp file to allow all http connections
d) browsed to the console domain IP; logged in with "admin" and "admin01"
e) ran the template install and used the HTTP option pointing to my laptop which was hosting the wamp server
f) entered the IP parameters and ran through the installation dialog
g) template was successfully installed
h) logged into the CM with ASA :)..

Hope this helps guys.

RE: Avaya - Midsize Business Template (CM 5.2)

I gave what you listed a try, after some hassle I managed to get System Platform installed and booting completely. Still have some network issues as I can't ping the CDom side of things or get the web interface. I tried adding static routes, and also playing around with the service port but still can't get it to work. I suppose one of these days I'll figure it out. Many thanks for the help getting the media though, can't try without that.

Thanks,
Anthony

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Yeap, that's the problem i got. try to disable any firewall / anitvirus sw you're running on the host machine. also, run a ping to Domain-0 and see if that responds; then ping cdom from Domain-0; if it answers you might just need to wait until cdom is fully booted up...takes forever to boot up the 1st time. You can check it's status by logging in as root on Dom0 and issuing the "xm list" command; next to the udom machine you will need to have an "r"..then you'd need to do that static route thing. Hope it works for you as well!

Cheers!

RE: Avaya - Midsize Business Template (CM 5.2)

Turn on promiscuous mode in the NIC config in your VMWare. VMWare, by default will let only the VM installed (Dom0) talk outside to other stuff. I had the same condition of my VMs in System Platform being able to ping Dom0, but nothing beyond that, and of my stuff outside dom0 not pinging stuff like CDom inside system platform.

Also, you need a default authentication file to get your proper permissions in CM VMWare.

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Hi Kyle,
Thanks for this. will have a look. The auth file is this one "asg_auth_file_6.xml" no?

Did you by chance run into issues with getting the Media Services IN SERVICE? I can ping it alright, it's configured in CM but shows OUT.. I've 4 NICs allocated to the Syst Platform virtual machine from ESXi (to match the manuals) but no luck with getting this up.

Tudor

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
I managed to run this by using only VMware Workstation so no ESXi. It installs right, i uploaded the auth file ( i ca do save translations in ASA) but still have the same problem with the Media Services IPSI. I can't ping it now.

I'm a bit curios as to why this isn't working as i've allocated 4 NICs on the virtual machine and they're all bridge to my real-life notebook NIC (i can ping all the VMs ex CM, AES, SES) but can't get anything from that Media Services IP. Why would this NIC not come up as like all the others? It's bridge the same way they are.

Really appreciate any tips if anyone got this one up.

RE: Avaya - Midsize Business Template (CM 5.2)

You start with the IPSI that controls the cards in the G650 gateway, then you have to administer it like a real cabinet!
"change node-names" - medpro1, 192.168.x.1, medpro2 192.168.x.2
add ip-interface 1a04, assign nodename, enable interface, etc

I only managed to get MediaServices in System Platform in VMWare ESXi... Console into your mediaservices VM and see what's up

RE: Avaya - Midsize Business Template (CM 5.2)

A few things just clicked back from when I did it...

In ESXi, I disabled the nx flag on the CPU of the VM, enabled promiscuous mode, set no limit (or a limit...can't remember) on the CPU, and when you start System Platform for MBT5.2.1 with media services, let everything start normally and then shut down your CM, SES, AES and just leave your 650 running. I recall that helping me get it up.

I'm sure with enough Linux-fu that a wise guy could VMWare Converter the MediaServices VM straight to VMWare and deal with the quirks of how Avaya deployed on Xen and how the Xen templates and VMWare aren't totally compatible...

RE: Avaya - Midsize Business Template (CM 5.2)

(OP)
Hi Kyle,

I've got it working in Workstation now. I reinstalled the whole thing and Media Services are up now and IPSI is IN service. Strange thing but it works :)

Cheers!
Tudor

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close