Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Error 909 (Invalid character)

Error 909 (Invalid character)

Error 909 (Invalid character)


i have migrated from TD2.0 to TD5.2.

when i try to call a stored procedure, i receive error 909 (Invalid character).

CODE --> Centura

Set strSqlPrepare = '{call ' || DACS99001 || ' ( :spBufferIN )}'
If OdrPrepareProc( hSqlixxx, strSqlPrepare, ':siValue' )

This works fine with TD2.0.

spBufferIN is a Long String (I tried String but it did not change anything). I had this problem solved in many files (not all of them) by deletting odbsal32.apl from the application folder. How do I do for the other files?

I hope anybody face this problem previously. So please guide me to solve this.


Léa M.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close