Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Setting up LLDP-MED properly

Setting up LLDP-MED properly

Setting up LLDP-MED properly

I am having a problem getting Shoretel phones to go into the voice vlan when connected to a Juniper switch. Switches are on current code and the Shoretel system is on 14.1. When the phone boots it appears to work since it pulls an IP from the voice vlan, but then it displays "Reconfiguring network", reboots and puts itself into the native vlan on the switch port. I have verified that the only DHCP option enabled is 156 and all it pushes is the FTP server IP. Not sure what I am missing and I don't have a lot of stick time setting up LLDP-MED, especially in Junos.

I can see the phone if I do a show LLDP neighbor. I used these commands to setup the ports.

4.Configure VoIP on the interface and specify the assured-forwarding forwarding class to provide the most dependable class of service:

[edit ethernet—switching—options]
user@switch# set voip interface ge-0/0/2.0 vlan voice-vlan
user@switch# set voip interface ge-0/0/2.0 forwarding-class assured-forwarding

5.Configure LLDP-MED protocol support:

[edit protocols]
user@switch# set lldp-med interface ge-0/0/2.0

RE: Setting up LLDP-MED properly

What make and model of Juniper switch do you have?

Real trouble call:
Customer: "I have a huge problem. A friend has put a screensaver on my computer, but every time I move the mouse, it disappears!"

RE: Setting up LLDP-MED properly

It's a 4200 series. So far I have found that if I disable DHCP option 156 and enable 66 instead I can get it to work. Shoretel was not able to tell me why option 156 and LLDP do not play well together.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close