×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

WindX Client Connection unable to connect to Server "192.168.0.5"

WindX Client Connection unable to connect to Server "192.168.0.5"

WindX Client Connection unable to connect to Server "192.168.0.5"

(OP)
Seems like no matter what we do we cannot get past this. This is running both the server and client on the server, therefore, not cabling nor hub involved.

Steps we have taken (with Sage support):
Checked the sota.ini
Checked adapter settings (using Internet Protocol Version 4 (TCP/IPv4) (set at "Use the following IP Address: 192.168.0.5 Subnet mask: 255.255.255.0 default gateway 192.168.0.1
Tested both as a service and as Application Server.
Tested launch via running directly from Providex.exe "startup.m4p
Still get WindX Client Connection unable to connect to Server "192.168.0.5"

When we change it to local loop back of 127.0.0.1, it all works fine!!!!

Per ID Manager, this is a new server with nothing else on it. I do see Wireshark loaded (I'm not familiar with it).
This is Microsoft Windows Server 2012 Standard.

What else could be blocking the "can't connect to server" problem???

RE: WindX Client Connection unable to connect to Server "192.168.0.5"

If you are attempting to run MAS on the server where the program is installed and I am assuming you are running MAS200 then you should be running it as MAS90. Works for me. You do this by right clicking on the desktop and creating a new short cut. Then paste in "{drive letter here}:{path to MAS}\MAS90\Home\pvxwin32.exe" -hd../launcher/sota.ini ../soa/Startup.m4p This is what is called running in MAS90 mode. You can or should be able to find more on the Knowledge base. Surprised that tech support did not have you do this. I learned this at the Sage Summit.

Visit Sage's Online Community
http://community.sagemas.com/sagemas/?category.id=...

RE: WindX Client Connection unable to connect to Server "192.168.0.5"

This is straight from the Sage Knowledge Base:

How to run Sage MAS 200 in "Sage MAS 90" mode
Entry Type: Informational

Product: Sage MAS 200 ERP, Sage MAS 200 ERP - SQL Server Edition

Application: Library Master

Version Reported: All

Subject:

How to run Sage MAS 200 in "Sage MAS 90" mode.

Possible Resolution:

Run Sage MAS 200 in "Sage MAS 90" mode to troubleshoot startup issues such as the following:

Errors on the screen that are otherwise disguised.
Network connection issues.
Other tasks that may require using a mapped drive instead of a UNC to retrieve the data.
Note: This method is not recommended for operational use for the following reasons:

It does not use the primary Sage MAS 200 features (for example: processing data at the server rather than the workstation, performance, network security)..
Users cannot "see" each other. Users in "Sage MAS 90" mode do not display in the Sage MAS 200 Master Console. Sage MAS 200 user do not display in the "Sage MAS 90" Master Console.
The correct toolbar bitmaps and HTML pages do not display on the Business Desktop (Launcher).
Sage MAS 200 4.xx

Map a drive to the parent drive or folder above the ..\Mas90\ folder (For example: F:\Apps\Mas90)
Note: The mapped drive is required. A UNC path cannot be used. Also, the "Sage MAS 90" user must have Full Control permissions to the ..\Mas90\ folder and all subfolders.
Perform either of the following:
Run Sage MAS 200 from the Providex prompt:
In Windows Explorer, go to the server's ..\Mas90\Home folder.
Double-click Pvxwin32.exe.
Type the following at the Providex prompt and press ENTER:
RUN "STARTUP.M4P"
Create a "Sage MAS 90" shortcut icon:
Make a copy of the Sage MAS 200 shortcut icon and modify the following fields in the new icon:
Target:
"x:\MAS90\HOME\PVXWIN32.EXE" (x = the mapped drive, or C if you are at the server)
..\launcher\sota.ini
..\soa\startup.m4p
Note: The quotes are required only if the path contains a space.
Start In:
"x:\MAS90\HOME"
Sage MAS 200 3.7x

Map a drive to the parent drive or folder above the ..\Mas90\ folder (For example: F:\Apps\Mas90)
The mapped drive is required. A UNC path cannot be used.
The "Sage MAS 90" user must have Full Control permissions to the ..\Mas90\ folder and all subfolders.
Perform either of the following:
Run Sage MAS 200 from the Providex prompt:
In Windows Explorer, go to the server's ..\Mas90\Home folder.
Double-click Pvxwin32.exe.
Type the following at the Providex prompt and press ENTER:
RUN "MAS90"
Create a "Sage MAS 90" shortcut icon:
Make a copy of the Sage MAS 200 shortcut icon and modify the following fields in the new icon:
Target:
"x:\MAS90\HOME\PVXWIN32.EXE" (x = the mapped drive, or C if you are at the server)
..\launcher\sota.ini
..\soa\mas90
Note: The quotes are required only if the path contains a space.
Start In:
"x:\MAS90\HOME"
Sage MAS 200 - SQL Server Edition:

Assign SQL database permissions to the user:
Note: This step is not necessary if you log on as Administrator. The trusted Windows Administrator will be mapped into the SQL Builtin\Administrators group, unless specific SQL Server security has been set up.
Note the user's Windows domain account.
Open a command prompt (Start / Run / CMD) and type SET.
Note the values for USERNAME and USERDOMAIN.
Have the SQL Database Administrator (DBA) assign the following database roles to domain account for the MAS_XXX and MAS_SYSTEM databases (XXX = company code):
DB_DataReader
DB_DataWriter
Create the MASSQL DSN driver to access the data.
Note: If you are at the server, this step is not necessary. The MASSQL DSN already exists.
At the Windows Start menu, click Control Panel.
Double-click Administrative Tools and Data Sources (ODBC) to open ODBC Data Source Administrator (or run Start / Run / ODBCAD32).
Click the System DSN tab.
Click the Add button.
Select SQL Server and click Finish to start the wizard.
Enter the following and click Next:
Name = MASSQL
Description = MASSQL
Server = The name or IP address of the SQL Server
Click the With Windows NT Authentication Using Network Login ID option button.
Click the Client Configuration button.
Click the TCP/IP option button, and OK to return to the authentication window.
Click Next.
Note: If "Logon Failure" or similar occurs, the user account does not have sufficient rights to the SQL Server. Close the window, give the user sufficient rights, and start over.
Select both of the ANSI check boxes, and clear all other check boxes. Click Next.
Accept the default selections and click Finish.
Click Test Data Source to verify the connection.
Create a "Sage MAS 90" shortcut icon:
Make a copy of the Sage MAS 200 - SQL Server Edition shortcut icon and modify the following fields in the new icon:
Target:
"x:\MAS90\HOME\PVXWIN32.EXE" (x = the mapped drive, or C if you are at the server)
..\launcher\sota.ini
..\soa\mas90
Note: The quotes are required only if the path contains a space.
Start In:
"x:\MAS90\HOME"

Visit Sage's Online Community
http://community.sagemas.com/sagemas/?category.id=...

RE: WindX Client Connection unable to connect to Server "192.168.0.5"

(OP)
What I didn't say is that when we try to connect a client that is different PC we kept getting the same error also. We have not been successful connecting any client that is loaded on another PC. So there must be something else causing this with other workstations?

RE: WindX Client Connection unable to connect to Server "192.168.0.5"

(OP)
If I wasn't clear, it runs fine in "MAS90 mode", so we are still back to the connection issue when not in "MAS90 mode".

RE: WindX Client Connection unable to connect to Server "192.168.0.5"

Can you ping the server both by name and IP address from the work station and can you ping the work station from the server? Also have you tried to connect the work station to another network port?

Visit Sage's Online Community
http://community.sagemas.com/sagemas/?category.id=...

RE: WindX Client Connection unable to connect to Server "192.168.0.5"

Try disabling your firewall on the machine.
Sounds like traffic is being denied to the "external" (not loopback) IP address.

Just my 2ยข

"What the captain doesn't realize is that we've secretly replaced his Dilithium Crystals with new Folger's Crystals."

--Greg http://parallel.tzo.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close