×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Copying a user profile

Copying a user profile

Copying a user profile

(OP)
Hi all

I have had to copy a user profile to a workstation. I did a retore of his data from the backup server and copied all his details. I exported his directory from the workstation to the server, and i can access his /home directory from the server. Problem is, i cannot login as the user. i can login as the already existing user. I can su to both users from root

From root, I can actually su to the new user profile. From there, I can su to the existing user. But if i su to the existing user, and from there to the new user, i get the following error:

uungerc-rsqa01:/home/uungerc#su - unortjea
unortjea's Password:
3004-501 Cannot su to "unortjea" : Authentication is denied.
uungerc-rsqa01:/home/uungerc#

I checked for expiration of password, but all users have a 0 value for that.

RE: Copying a user profile

Hmmm,
What version of AIX OS are you running?

Check for "account_locked" attribute of the user unortjea, is it true or false. If it's true change it to false.

SARFARAZ AHMED SYED,
Sr. Systems Engineer

RE: Copying a user profile

(OP)
His workstation used to be AIX 4.3, the new one is AIX 5.3. His account_locked attribute was already set to false.

RE: Copying a user profile

Can you paste the .profile output?

RE: Copying a user profile

I suggest you login as root, force set the password for the user and then try to login. This may be as simple as a wrong password.
If this does not help, please paste the output of lsuser unortjea. Since you are testing by issuing su - it has to be set: su=true.

RE: Copying a user profile

(OP)
Hello,

I used passwd unortjea, and then changed the password. I then logged in as unortjea, but was prompted to change the password. As soon as i did that, I got and error and the login screen went blank( I used X-Win to access his workstation). I don't know where that error will be logged. I first tested it on a test user that i setup years ago, and i worked for that user.

Output of user's .profile:

set -o vi
VISUAL=/usr/bin/vi
PATH=$PATH:/usr/local/vwbin:/usr/local/bin:/usr/local/lib:/vw/vwsa/cadview/cadview2.27D
export VISUAL PATH

if [ -s "$MAIL" ] # This is at Shell startup. In normal
then echo "$MAILMSG" # operation, the Shell checks
fi # periodically.
export PS1="$USER-`uname -n`:\$PWD#"
alias l="ls -lt"
alias df='df -k'
#The following line is added by License Use Management installation
export PATH=$PATH:/var/ifor:/usr/opt/ifor/ls/conf

#The following is required for CADVIEW to find its configuration settings
PATH=$PATH:/vw/vwsa/cadview/bin/
CVFILEPATH=/vw/vwsa/cadview/cadview2.27D
export PATH CVFILEPATH

# Konzern Referenz environment variables
K_PATH=/vwsa
K_DATA=/vwsadat

V4_LOCGII=/vwsa/catia/local/gii
V4_LOCIUA=/vwsa/catia/local/iua

export K_PATH K_DATA V4_LOCGII V4_LOCIUA

PATH=$PATH:/$K_PATH/catia/bin:/vwsa/catia/local/gii:/vwsa/catia/local/iua:/vwsa/bin

export AudimessDoc=/vwsa/catia/local/gii/man/audimess/IQMDOKU

export PATH

export MyEditorIs='/usr/dt/bin/dtpad'




Output of luser unortjea:

unortjea id=361 pgrp=qagrp groups=qagrp,plossys home=/home/unortjea shell=/usr/bin/ksh login=true su=true rlogin=true daemon=true admin=false sugroups=ALL admgroups= tpath=nosak ttys=ALL expires=0 auth1=SYSTEM auth2=NONE umask=22 registry=files SYSTEM=compat logintimes= loginretries=0 pwdwarntime=0 account_locked=false minage=0 maxage=0 maxexpired=-1 minalpha=0 minother=0 mindiff=0 maxrepeats=8 minlen=0 histexpire=0 histsize=0 pwdchecks= dictionlist= fsize=2097151 cpu=-1 data=262144 stack=65536 core=2097151 rss=65536 nofiles=2000 time_last_unsuccessful_login=1384802818 tty_last_unsuccessful_login=t-systems1_vwza_ host_last_unsuccessful_login=t-systems1.vwza.emea.vwg:1 unsuccessful_login_count=22 roles=


RE: Copying a user profile

(OP)
Hi guys, I tried to change his password again, for some reason it worked now. I logged in and everything seems fine. I was so sure it couldn't be something as simple as changing his password, since he has used the same one for many years now, I actually still remembered his password.

Thanks for the help

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close