Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Can't 'see' all .rpt files published on CMC

Can't 'see' all .rpt files published on CMC

Can't 'see' all .rpt files published on CMC

Using Crystal Reports 2008 SP8 connecting to Business Objects CMC (version 3.?)

From crystal reports I can connect and access the .rpt files published on the Enterprise server. My problem is that I cannot see/access all of the .rpt files in some folders. It's not a random .rpt file, the report list is definitely truncated (example: I can see reports A through L and am missing everything from M through Z). There must be a registry setting that limits the number of files to fetch, but I don't know the registry name.

I'm assuming that it's a crystal reports limitation as I am able to access all of the reports using APOS InfoScheduler. I had a similar issue with not being able to see all of the tables and views on our SQL database from crystal, but a change in the Crystal Reports registry setting fixed that issue.

Thanks for your help.


RE: Can't 'see' all .rpt files published on CMC

When there are more than a certain number of reports (I don't remember how many that is), the list of reports will be "paged" when looking at them from the Save screen in Crystal. There should be an option at either the top or the bottom of the Save screen that will let you go to the next page of reports. Unfortunately, I don't have a system set up that has enough reports that I can look at it to see exactly how this is labeled or where it's at.


DecisionFirst Technologies - Seven-time SAP BusinessObjects Solution Partner of the Year

RE: Can't 'see' all .rpt files published on CMC

Thanks Dell, but that's not the issue.

I'm trying to open the .rpt file using Crystal Reports, not through CMC or InfoView.

In Crystal Reports I do a File - Open, then select Enterprise from the 'Open' dialogue box. I'm presented with the folder structure on the Enterprise server. There are folders that I am unable to see all of the .rpt files in the tree. There is no ability to move to an additional page.

I understand the paging funciton when I access the reports using CMC.


RE: Can't 'see' all .rpt files published on CMC

I'm saying that there should be a way to page in that Open dialog in Crystal (I used "Save" because I rarely open from BO.) It's not obvious on the screen, but in Crystal 2008 it should be there.


DecisionFirst Technologies - Seven-time SAP BusinessObjects Solution Partner of the Year

RE: Can't 'see' all .rpt files published on CMC


Thanks for the clarification. I started clicking around and I found it! You have to right click the folder that contains the 'missing' file. You will be presented with 5 options:
- First Batch
- Next Batch
- Previous Batch
- Last Batch
- Find

Clicking on 'Next Batch' brought up the next group of 'missing' reports.

The 'Find' function worked as advertised as well.

Thank Dell for taking the time to share and explain your answer. I am very grateful.


RE: Can't 'see' all .rpt files published on CMC

Hey Steve053,

Any idea how you got the Enterprise access between your Crystal Reports and the Enterprise Server working?

We have our server up and running and can log in via CMC and BI Launchpad, but we are unable to connect from Crystal Reports Developer [desktop app] to the Enterprise. I suspectot that something needs to be installed or configured on the server side but do not know what. I only have server access via CMC and BI Launchpad. Everything else, Server Installation, Windows Server 2008 OS related, etc is done by our Server Admin group. They know about as much as me when it comes to Crystal Server administration. It is hard for me to request them to install or configure something that I do not know. I am hoping someone might be able to shed some light on where to look,what to ask, etc.

I currently access the server BI Launchpad via the following:
System: [EnterpriseServerName:6400]
UserName: [MyName ]
Password: [MyEnterprisePW ]
Authentication: [Enterprise ]

When I am in Crystal Reports desktop and try to open a report on the server via Enterprise, I am prompted with the following:
Log On to BusinessObjects Enterprise
Enter the name of your syste, (Central Management Server).
You also need to specify your user name and password.
System: [ ]
User Name: [ ]
Password: [ ]
Authentication: [ ]

I have tried using the same credentials as for BI Launchpad and CMC but get the following error.
Internal Error. An unkown exception has occurred.

- Bill

RE: Can't 'see' all .rpt files published on CMC


Which version of BOE or Crystal Server are you connecting to? Which version of Crystal are you using?


DecisionFirst Technologies - Seven-time SAP BusinessObjects Solution Partner of the Year

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close