×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Field on form refuses to update table using simple ObjectPal - what am I missing?

Field on form refuses to update table using simple ObjectPal - what am I missing?

Field on form refuses to update table using simple ObjectPal - what am I missing?

(OP)
Hi All,

I have an old customer that is still running Paradox 7 and they asked me to make a few changes for them on a application I wrote for them. There is a field defined that basically says if the value of this field = YES then update the following fields with the specified data. They wanted me to add another item to this which I did and it will not update the table for some reason, the other items update just fine and even the items that I remarked out in the past will update if I add them back in, but not the new field.

I have checked , rechecked and triple checked and the field in the table and the field in the form are identical. I tried deleting some old no longer used fields in the table in case I had exceeded the max fields per table, no dice. I changed the field from a numeric to a Alpha, no dice.

I've been beating my head against this wall for the last 4 hours and I can't figure out what's wrong. Hopefully someone can look at it and go oh, you need to do this. I just don't get it, it just refuses to acknowledge and populate that field in the table from the code below.

Thanks

Gordon

Here is the code

method action(var eventInfo ActionEvent)

if addrlbls = "NO" and packagea = "YES" then

disabledefault

msgstop("ALERT","address labels box must be checked with a valid address before continuing")

addrlbls.moveto()

else

if packagea = "YES" then

disabledefault

pkgenvslqty = 10 ; Qty chnaged fom 5 to 10 for 0910

packageann = 50

PKGSWEAT = 1 ; This is the new item I've added the field is numeric short. All the others work just fine

packagenmcrd = 100

;pkgmdploma = 1 ; I restored this one and it worked just fine.

pkgpremks = 1

;pkganncvr = 1 Removed for 0910 changes

pkgaddrlbls = 3

pkgmembkd.moveto()

endif

endif

endmethod

RE: Field on form refuses to update table using simple ObjectPal - what am I missing?

Simplistic suggestion I know but don't forget that Paradox is case sensitive. I only say this because it jumps out at me that your PKGSWEAT field is in block capitals in your code while all other fields are lower case. Is it possible that the field naming convention in your database table is lower case?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close