×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Using eConnect to insert/update RMA's and serial line items

Using eConnect to insert/update RMA's and serial line items

Using eConnect to insert/update RMA's and serial line items

(OP)
I am using econnect to insert and update RMA's and am receiving the following error when inserting a new serial number. It keeps referring to specifying something that already is specified, in this case SVC_Original_Serial, I set it and in my code I also set SVC_Original_SerialSpecified = true;
I am wanting to create a custom receiving app to receive the serial number items in. I created one already and got one to receive in but when I try to receive another in I get the following error.


Sql procedure error codes returned:
Error Number = 10024 Stored Procedure= taFSRMALineSerial Error Description = Invalid Original Serial Flag (SVC_Original_Serial) - Value can be 0=No, 1=Yes

Node Identifier Parameters: taFSRMALineSerial

Return_Record_Type = 1

RETDOCID = RMA0KFP000001

Related Error Code Parameters for Node : taFSRMALineSerial

QTYTYPE = 2





<taFSRMALineSerial>

<Return_Record_Type>1</Return_Record_Type>

<RETDOCID>RMA0KFP000001</RETDOCID>

<CUSTNMBR>BBTFINANC027494</CUSTNMBR>

<ADRSCODE>PRIMARY</ADRSCODE>

<LNSEQNBR>200</LNSEQNBR>

<QTYTYPE>2</QTYTYPE>

<ITEMNMBR>VX510 DC</ITEMNMBR>

<SERLNMBR>4-4-4-4</SERLNMBR>

<LOCNCODE>RETURN</LOCNCODE>

<SVC_Original_Serial>0</SVC_Original_Serial>

</taFSRMALineSerial>

RE: Using eConnect to insert/update RMA's and serial line items

(OP)
Found the problem, it helps when you create the object with the proper line count.

taFSRMALineSerial_ItemsTaFSRMALineSerial[] serialitems = new taFSRMALineSerial_ItemsTaFSRMALineSerial[LineCount];
taFSRMALine_ItemsTaFSRMALine[] lineitems = new taFSRMALine_ItemsTaFSRMALine[LineCount];

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close