×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Unidentified OID but works when path is specified... strange

Unidentified OID but works when path is specified... strange

Unidentified OID but works when path is specified... strange

(OP)
Ok trying to get snmp working. The path to the MIBS is set in snmp.conf. However when I do this from the command line --

snmptranslate -m +Forescout_1.txt -On scoutId

I get Unknown object identifier: scoutId

if I specify the path in the command

snmptranslate -m +/usr/share/snmp/mibs/Forescout_1.txt -On scoutId

it give me back the OID.

Any thoughts? Thanks!


RE: Unidentified OID but works when path is specified... strange

I am not that familiar with snmptranslate but my only guess would be specifying on the command line tells it which MIB to search.

Might be better to ask this directly to the net-snmp guys.

Bill

RE: Unidentified OID but works when path is specified... strange

(OP)
Ok still trying to solve this

The problem is crazy.

If I enter the total path to the MIBS --
money@secden-nagios80:~$ /usr/bin/snmptranslate -m +/usr/share/snmp/mibs/ForeScout_1.mib -IR -On scoutId
.1.3.6.1.4.1.11789.4.1.1.1

but if I just enter the name and not the path it can't find it but you can see it does have the correct path that it's searching through --
money@secden-nagios80:~$ /usr/bin/snmptranslate -m +ForeScout_1.mib -IR -On scoutId
No log handling enabled - turning on stderr logging
MIB search path: /home/money/.snmp/mibs:/usr/share/mibs/site:/usr/share/snmp/mibs:/usr/share/mibs/iana:/usr/share/mibs/ietf:/usr/share/mibs/netsnmp:/usr/share/snmp/mibs
Cannot find module (ForeScout_1.mib): At line 6 in (none)
Unknown object identifier: scoutId

very frustrating!

RE: Unidentified OID but works when path is specified... strange

Could always try strace or truss, maybe that would help??

Bill

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close