×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Move Content DB error content DB does not exist

Move Content DB error content DB does not exist

Move Content DB error content DB does not exist

(OP)
I was attempting to move our content DB to a new server as the one it is on is currently being retired. There are only the Search Services DB and a single content DB located on this server. I am using the following command: "stsadm -o preparetomove -contentdb oursharepointserver\officeservers:WSS_Content -site http://oursharept" and I receive the error "A content database with the name WSS_Content does not exist on the specified server instance". Now I have confirmed the name of the content DB on the SQL server is WSS_Content and in the Central Administration page I have viewed site http://oursharept and found that the content DB is also listed as WSS_Content. Is there another way to determine what the name of our content DB is? Is there another way to do this? I was thinking of going the route of "stsadm –o deletecontentdb –url http://oursharept –databasename WSS_Content –databaseserver CurrentDB | stsadm –o addcontentdb –url http://oursharept –databasename WSS_Content –databaseserver newSQLDB" but I am a little nervous since the system does not recognize the current DB by name and I do not want to take the system down and not be able to bring it back easily. Unfortunately we have no dev environment here for this so any irreversible issues that cause the system to fail will result in me doing a full restore of the farm from backup.

RE: Move Content DB error content DB does not exist

(OP)
This ended up being a parameter being incorrect in the command. The content DB was incorrect.

RE: Move Content DB error content DB does not exist

(OP)
FYI the command "stsadm.exe -o enumcontentdbs" allowed me to view the content DBs to help determine the issue

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close