×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Adding Netware 5.1 Server to Existing Tree

Adding Netware 5.1 Server to Existing Tree

Adding Netware 5.1 Server to Existing Tree

(OP)
I support a legacy system (to be replaced soon) which will only run on Netware 5.0/5.1. I have just added a 5.1 server to a single server 5.0 existing tree. There are now two servers in the tree. I have installed the licenses for the 5.1 server thru NWAdmin and made the assignments to the 5.1 server.

I keep getting an error message stating that "Connection x is using a 'grace' connection to New_Server because no licenses were installed or available....". I read in another forum that this problem could be resolved by installing a DS replica on the new server. I initiated this process over a week ago and the replica still shows as "New" as opposed to "On" and I still get the message. Have run DSRepair several times.

Any suggestions would be appreciated.

Thanks,

RE: Adding Netware 5.1 Server to Existing Tree

You probably should have upgraded the Edirectory (NDS) version on the 5.0 box to be the same version running on the 5.1 box. What version are you running on each? You may have to cancel the ADD REPLICA and get the two NDSs at the same level.

See this whole article, but particularly the "BEFORE YOU START" section. You should have done a health check on the original first.
http://www.novell.com/coolsolutions/appnote/15969....

Check this thread for Edirectory how to:
http://support.novell.com/techcenter/articles/ana1...

I would do this at each server (type in order as shown) to display what's being synchronized and what might be hanging.
set dstrace=on
set dstrace=+S
set dsctrace=*H


Read this later:
http://www.novell.com/documentation/edir873/?page=...

RE: Adding Netware 5.1 Server to Existing Tree

You could also add this string to the dstrace commands above to show partition activity and YES, I did misspell the one DSTRACE line above. Restated:

set dstrace=on
set dstrace=+S
set dstrace=*H
set dstrace = +part

RE: Adding Netware 5.1 Server to Existing Tree

(OP)
Thanks for the suggestions. I am sure you are correct that I should have done the health check.

I will read the recommended documentation and try your suggestions.

Thanks again,

RE: Adding Netware 5.1 Server to Existing Tree

(OP)
OK, I am sure that I have a hang up in the creation of the replica on the 5.1 server and I'm pretty sure it is because of two different versions of NDS. You alluded to the fact that I could cancel the ADD REPLICA function but I don't see a clear way to do that. I have looked at the options in NDSmgr and NWAdmin and don't see that option. Can you suggest a way to do the cancel?

Thanks,

RE: Adding Netware 5.1 Server to Existing Tree

I never had one that stayed stuck, so follow this TID and what it says, then go to the very end if absolutely necessary. Time synchronization is very important for nds synchronization so check that first.

http://www.novell.com/support/kb/doc.php?id=700312...

If it comes to the nuclear option (dsrepair -XK2), I'm hoping Marv will show up with some good advice.

When you get the replica removed, make sure to repair the NDS on the original box and use the dstrace to see that there are no issues over a period of a day or so BEFORE you to try to update both boxes to the latest NDS supported which is all BEFORE you try to ADD replica again.

RE: Adding Netware 5.1 Server to Existing Tree

I guess I might as well be the one that tells you that you are running a very outdated version that is not supported any longer AND I don't seem to see a place to download Novell patches/service packs. So it might be tough to get the NDS and other updates you need. You may have to try the replica ADD with the differing versions (assuming they are???) after a health check.

RE: Adding Netware 5.1 Server to Existing Tree

(OP)
Thanks again. Yes, I know we are in an outdated and unsupported environment. I am just trying to keep it going a bit longer until new software can be chosen and implemented. In the worst case, I do not need to add the second server to the current tree since it will be used only as a backup.

I really appreciate your help,

RE: Adding Netware 5.1 Server to Existing Tree

Are we done?? Post results when you do something.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close