×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Unable to delete files

Unable to delete files

Unable to delete files

(OP)
Hello, NetWare pros:

I recently started a job for a NetWare 6.5 shop and I'm relatively inexperienced with the OS.

We have a server that used to host home directories for all students K-12. Recently, the box began to misbehave. It would first begin to run very slowly, then it wouldn't allow users to access resources, then it would stop responding to commands at the CLI. I didn't know of another way to bring it down other than to hold the power button. After it would come back up, I'd run dsrepair and get the time synced back up. I moved some of the student files over to a new server I built to spread the load, in case the troublesome box was overburdened.

Now, we have various files that we are unable to delete, either from a Windows workstation (CMD and Explorer) or from the server itself through nsninit/nsnshell. Windows says it "cannot read from the source file or disk" and NetWare just says it cannot delete it.

Have any of you run into this before? Are their any health checks/repairs I can run on the volumes if there are corruptions? Is it somehow possible to remove these "gunk" files?

Thanks in advance!

RE: Unable to delete files

I've got to ask this question: how did you get a job in a Netware environment without much Novell experience?? As the tech!?

First:
Is it a single hard drive in the server or RAID of some kind? If a single drive, the drive might just be going bad, thus explaining the funkines. If single drive, boot to the manufacturer's diagnostic tool and test it. If a RAID array, you might do a "Verify with Fix" or whatever the equivalent is for that RAID controller to make sure the array is kosher.

If no problems found above, then
See this thread if NSS volumes
http://www.tek-tips.com/viewthread.cfm?qid=908493

If not (traditional volumes), run Vrepair a couple times.
http://www.novell.com/documentation/nw6p/?page=/do...

RE: Unable to delete files

(OP)

Quote (goombawaho)

I've got to ask this question: how did you get a job in a Netware environment without much Novell experience?? As the tech!?

A perfectly valid question. The person I replaced remains with the department and helps me out with NetWare-related issues/projects (they're stumped on this deletion problem as well). Admittedly, the plan is to migrate away from NetWare in the future -- either to OES-Linux or Active Directory.

The hard drives are in a RAID 0 configuration.

Thank you for the suggestions, I'll try them as soon as I get a chance.

RE: Unable to delete files

Thanks for answering my query. I always want to know how people end up in these jobs and are like, "I've never supported this........ so help me out." I would never want to be in that position and feel inadequate.

Quote:

The hard drives are in a RAID 0 configuration.
Seriously - that's just about a crisis right there. That's not generally considered a WISE configuration for data or O.S. drives on a SERVER. Kind of crazy risky!!

So, I recommended troubleshooting in the order that I did because if one of the hard drives in the RAID 0 is failing, that could cause funky behavior in the O.S. and be totally unfixable in the O.S.

RE: Unable to delete files

(OP)
Health checks on the RAID show green. When I attempted to run NSS /POOLVERIFY, the server appeared to lock up (sort of). The hard drive lights went solid green, no blinking whatsoever, and the command line was unresponsive. I could, however, access Remote Manager and launched an emergency console and tried to down the box. It sat there for nearly an hour doing nothing.

I forced the shutdown and booted. Once the server came up, I attempted to delete the files that wouldn't delete earlier, out of curiosity. I could delete them.

I'm planning a migration of the data to an older, stand-by server so I can rebuild the problem child with RAID 5 and do a fresh NetWare install. I'm not sure if it'd be time-efficient to try and continue the gremlin hunt...

RE: Unable to delete files

Let me ask you this. Had you NOT tried to shut down the server, restart it and then try to delete the files after the reboot? How long had the server been running since last reboot?? Because it hung up, something was wrong that a reboot fixed (memory leak, NLM gone wild).

You know - the famous IT fix: REBOOT please and try again. It sounds like B.S. but it fixes problems in windows and maybe Netware as well.

RE: Unable to delete files

(OP)
I absolutely agree with the reboot fix. When the server first began to act up, a reboot is the first thing I attempted to do. But the box would never go down all the way. It had been 11 days since the last reboot.

I'm going to migrate the data to a temporary box, rebuild, and migrate back. I really appreciate the help goombawaho, I'm sure I'll be back to post some NetWare newbie questions some time!

RE: Unable to delete files

Quote:

It had been 11 days since the last reboot.
That's not enough to cause any problems unless there's an underlying issue with hardware (memory perhaps). I was thinking more like 500 days without a reboot!! Do a memory test on that server before reloading.

You know there's a procedure somewhere for migrating the identity of the server (edirectory name, etc.) to another piece of hardware so you can do a hardware upgrade. Then all the server rights/roles/volumes will be preserved instead of removing the server and re-adding it. If you want it, I can track it down.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close