Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Actuate 11 - ROI crashes (corrupted ?), but only when TOCNeeded option is set to "Yes"

Actuate 11 - ROI crashes (corrupted ?), but only when TOCNeeded option is set to "Yes"

Actuate 11 - ROI crashes (corrupted ?), but only when TOCNeeded option is set to "Yes"

Hello World,

I have a problem with my reporting in Actuate 11.

When I activate the option "TocNeeded" of my report, it seems the ROI crashes.

In the viewer window, I can see the quantity of page generated evolve normally when my report is building... (1,2,3,4,...) and I can see in the status bar "viewing page 1 of 1,2,3,4...".

At a certain time, however, it seems the ROI is corrupted or something like that, and the viewer displays "viewing page 1 of 0" (and the arrows used to scroll through the pages of the report disappear). When I try to open the ROI, it says "this report does not contain anything".

When I desactivate the option "TOCNeeded", the report is built completely without errors.

I tried to debug but didn't find anything.

When I try debugging in step-by-step mode, I receive an uncomprehensible error when trying to close the POSM memory in rptroot.bas (--> after my main Report component is finished...)

I don't know where to look / what kind of error to search as I made many modifications in my reporting with "TOCNeeded" option desactivated and get this error now when I want to activate it again.

Recently, I tried to use a "render profile" but I set back the render profile option to the default values and this didn't solve my problem... so this is most likely not the cause of the problem.

Do you have an idea ?

Thanks for your help,

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close