×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Using an Object Element to Go to Bookmark in HTML File

Using an Object Element to Go to Bookmark in HTML File

Using an Object Element to Go to Bookmark in HTML File

(OP)
Hi.

I'm trying to reference a bookmark using the object tag element.

I've tested this in Safari and Firefox, same files different results. Firefox jumps to the section in the object element with no issues. But Safari merely loads the iframe.html file and doesn't jump to the bookmark.

My test.html

CODE -->

<html>
<head>

<body>

<div><object data="iframe.html#section4"></object></div> 

</body>
</html> 

My iframe.html

CODE -->

<html>
<head>

<body>
<a href="#section4">Section 4</a>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
<a id="section4">Section 4</a><br>
You have reached section 4.
</body>
</html> 


Any ideas why there is inconsistent behavior and is there work-around?

Thanks.

Philip

RE: Using an Object Element to Go to Bookmark in HTML File

(OP)
I was merely experimenting with it. Of course I can use an iframe, and I'm doing that now. Just wondering why it doesn't work in Safari,but in Firefox. Anyway I filed a report to Apple about this bug, since it still doesn't work with the latest version of Safari.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close