×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

ActiveX Install Issue - Need help Please !!

ActiveX Install Issue - Need help Please !!

ActiveX Install Issue - Need help Please !!

(OP)
In attempting to deploy an ActiveX installation via Microsoft System Center 2012 we have run in to an issue. It being deployed to about 1000 computers and at best guess about 200 machines are seeing this issue.

On some machines when the user goes to the webpage where the ActiveX is called it will pop an install and try and install the ActiveX control again. These will usual result in an error of "2753 File XXX not marked for installation." If the user hits OK on the message (for some users once other users 3 times), it will let the user log in to the application. When the user then gets to the page that is actually using the ActiveX control they have to repeat the process, but the ActiveX control loads fine then on the page and the control functions fine. It appears basically for some reason the install did not complete successfully and it thinks it is not installed for that user. I think the error 2753 is not the root cause of the issue, because if you read below I can get it to where that error goes away.

What I have found is if another user logs in to the computer or someone with an existing profile logs on to the computer the ActiveX control works fine. We had saw this issue in testing and so the software push was done when the user was not supposed to be logged in, but some people still get the error even though they were not logged in.

A little background info. This is happening on XP 32, Win7 32 and 64bit clients with IE8 or IE9 (there are no IE7 installs left). All users are local admins. System Center runs under a different domain account that is in the local admin group and supposedly does the install under those credentials. These machines can all have different configurations of various software, there no common version of software I found on them other than all machines have Office 2010 and Symantec Endpoint Protection 11, but all computers have this installed, not just those that have the issue.

There is an Event ID of 1001 being written that "Detection of product '{31A4270F-F852-4201-9243-72ABA2CB36DF}', feature 'OcxFiles' failed during request for component '{C64E8F0A-F067-4BE4-BCC4-44F6A49A8946}'" each time the installer tries to run. I registered the component that is referenced with the second GUID and verified the ocx control is present on the machine. There is no corresponding Event ID of 1004 that generally comes with this message from what I read on a MS KB article.

I have tried uninstalling the ActiveX and used IOBit Uninstaller to clean up the install along with manually searching the registry for keys left behind and then manually installing the ActiveX using the MSI file provided by the software vendor. What happens then though is the next time that user goes to the website the 2753 error is gone, but the installer will pop up and loop continually until you hit cancel.

What I did find, is by uninstalling the application, deleting the local profile for the user that is having the issue and then re-installing the ActiveX it works fine, but this will be a last resort effort. With about 200 machines having issue and that will be a lot of manual effort to restore the user profiles back after deleting them.

I am stumped with this one and so is the software developer. I am tried different reg cleaners and what not, but can't find what still resides either in the registry or somewhere in the user's profile.

BTW I have yet to see this issue come up when doing the install manually using the MSI package outside of the software push, but it has been very random when it appears and have only installed it manually on about 15 computers.

Any ideas or suggestions are very much appreciated.
Steve

RE: ActiveX Install Issue - Need help Please !!

I had a similar problem when scripting the application of an ActiveX across 100's of machines. After a bunch of trial and error, the resolution came with some conditions.

- The web applications [domains] that require the activeX need to be in the Trusted Site Zone.
- Both TSZ security settings, "Downloads: Automatic prompting for file downloads" (1803) and "Downloads: Automatic prompting for file downloads" (2200) were set to Enable.
- Popup blocker was disabled for this domain.
- These rules needed to be applied to ALL user SIDs in HKEY_USERS, including the .DEFAULT key.

Also, check that you don't have a GPO setting/policy for new user profiles that will trump your efforts. This was the case in our domain.

-Geates

"I do not offer answers, only considerations."
- Geates's Disclaimer

http://raqxtr.sstar.com/caspdoc/html/vbscript_lang...

RE: ActiveX Install Issue - Need help Please !!

(OP)
Thanks Geates - will check in to these and let you know what I find.. appreciate the response.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close