×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

NPX 3.0 error related to installation of Windows Streaming Services cannot start service 2147024894

NPX 3.0 error related to installation of Windows Streaming Services cannot start service 2147024894

NPX 3.0 error related to installation of Windows Streaming Services cannot start service 2147024894

(OP)
This one is another of the errors that are directly related with Windows and really surprised me.

It seemed a little problem with the Windows Media Services (WMS), service did not start, so I opted for removing the server roll and adding it again after reboot,

I got an error.
(please see the pics or open the links to the pics if not visible)

http://www.picvalley.net/v.php?p=u/1595/3574976971...

The problem did not correct, and it causes a series of errors everytime the system is rebooted or the service, they are identified with this number 2147024894 (which have many related solutions but for componentes different to WMS)



http://www.picvalley.net/v.php?p=u/2866/1150403853...

About the error it showed every time that its started, the event viewer show this:
The Service Request Subject: System is showing frequent events like this: The Windows Media
Services service terminated unexpectedly. It has done this 23 time(s).

note: none of the nice logs showed any issue, everything is working right from Nice Side.

It seems an issue to dig in into windows, but have no idea... any hint would be helpful
Thanks.

=== remember that NICE is not so nice ===

RE: NPX 3.0 error related to installation of Windows Streaming Services cannot start service 2147024894

(OP)
Hello nice12345

I've seeked this document in former deployments.
That's the weird, this "error" appeared spontaneously, and could not be corrected with removal and reinstallation of WMS.
the NPX server in some moment was moved from physical location, and LAN IP address was changed, after that it seems that the error came.

I also tried removing the WMS and re-running the prerrequisites DVD for 2008, it drops me a "finished installation" but the WMS error is the same.

Nice Crew told me to run the "host renaming tool" and I did so, but since theres no a name change as that, the tool just ends working saying that no changes were done.

I am counting several days with this trouble, and wondering if the only solution can be reinstall windows, and therefore NPX.

Thanks.

=== remember that NICE is not so nice ===

RE: NPX 3.0 error related to installation of Windows Streaming Services cannot start service 2147024894

(OP)
nice12345, I thank you again.

According to this guide this should be done when HOSTNAME is change, which is not the case (there has been not a hostname but and IP address change which was rolled back), anyway I did it, I removed WMS, rebooted server, reinstalled WMS, and the service will not start!

I applied the script via command line but with the WMS stopped it’s likely the script has nothing to do.

I even dug deeper into and uninstalled the KB934518 hotfix, doing that the WMUS_HOSTNAME is deleted, so any relationship with the user should also dissapear..., rebooted server and reinstalled the WMS, and guess... the service will not start!

I remember to had a similar problem when installing IIS (not on nice) suddenly i could not start, even uninstalling and reinstalling, this was related with something like "registry keys" / database, which had to be eliminated before continuing, the documentation available on WMS is scarce, still fetching.

[PAG 37 of NPX Troubleshooting Guide]
Error 3505 After Renaming Machine
Symptom:
3505 error appears stating that channel monitoring failed.
Cause:
NICE Perform eXpress uses the NICE Playback Streaming service, by means of the Windows
Media Services component, to monitor channels in real time. When the Windows Media Services
component is installed a user is created. This user includes the machine name. For example, a user
might be WMUS_HOSTNAME where HOSTNAME is the name of the machine where Windows
Media Services is installed.
When the machine name is changed, the name of the user includes the previous machine name.
Therefore, the Windows Media Services fails to handle the NICE Playback Streaming service
request to monitor the channel.
Solution:
You must uninstall Microsoft Windows Media Services and then reinstall it again so that the
machine name will be correct for the Windows Media Services user. After reinstalling the
component, you run the AddPublishingPoint.vbs script to create an on-demand Publishing
Point, which adds the NICE Stream Server as a content source.
To troubleshoot:
1. From the Control Panel, select Add or Remove Programs. The Add or Remove Programs
window appears.
2. In the Add and Remove Programs window, select Add/Remove Window Components. The
Windows Components Wizard appears.

=== remember that NICE is not so nice ===

RE: NPX 3.0 error related to installation of Windows Streaming Services cannot start service 2147024894

(OP)
Ladies and gentlemen, the case is closed

what was the remedy? full Operating System Reinstall.
Even before that I tried with the uninstallation of IIS and all its components, after reboot, the WMS would keep its annoying error message.

Until today I am not sure what generated the error, but I suspect that was the running of the prerequisites DVD for 2008 once again when the system was running NPX 2.1

=== remember that NICE is not so nice ===

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close