×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Report refreshes with saved data parameter

Report refreshes with saved data parameter

Report refreshes with saved data parameter

(OP)
Hello,

I'm using CR2008 going against stored procedure in Oracle. I have a report using saved data as well as formula in saved data selection area. The report is complicated and thus takes about 15 mins to refresh. Therefore, I am using a parameter to filter from saved data. This seem to work just fine when running the report directly from Crystal Reports. However, when viewing in InfoView or Business Objects Enterprise 11, report refreshes whenever parameter is changed. Is there setting or configuration I may need to change? Any thoughts? Thanks.

RE: Report refreshes with saved data parameter

Select the report in CMC, select Properties tab, then Refresh Options. By Default all are checked. Uncheck record and group selection formula options.
Also, look at the options under Process/Parameters, it isn't made clear that to make user-keyed parameters work, you need to click on the parameter listed underneath the heading "Value" which may say [empty].This opens up other options to tick such as 'Prompt the user for new value/s when viewing' and 'clear the current parameter'.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close