×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

HP 2620 SW

HP 2620 SW

HP 2620 SW

(OP)
Hello,



Hello i configured a sw 2620 as an acces switch I defined 1 vlan in order to connect phones there, i already integrate with my Cisco Switch 3750X, my only issue with the HP is that i can not ping to the VLAN IP even its connected some equipments to the switch, i attached the configuration.



interface 25
speed-duplex 100-full
exit
interface 26
speed-duplex 100-full
exit
interface 28
speed-duplex 1000-full
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-28
ip address dhcp-bootp
exit
vlan 6
name "VLAN6"
ip address 10.10.4.10 255.255.255.0
tagged 23
exit
snmp-server community "public" unrestricted
spanning-tree priority 0



The spanning tree is not enable because i will use this HP connected like daisy chain,

The idea to reach the IP is to monitor the equipment by snmp

I can not even reach the HP by ping even i configured the port in the cisco like access port.

Thank you.

RE: HP 2620 SW

So if the idea is for you to communicate with the 10.10.4.10 address from your Cisco, you will need to create Vlan 6 on the Cisco and trunk the port that's linked to port 23 which is tagged on your HP. Might help a little more if you posted your Cisco config...also,you need have routing enabled on the Cisco end.

RE: HP 2620 SW

(OP)
thank you for your reply, i already configured the ip routing in the cisco switch.


vlan 6
description datauser
ip address 10.10.4.1 255.255.255.0

the port configuration its like this:
inter giga 1/0/37
switchport mode access
switchport access vlan 6

I only use the port as a access in the Cisco 3750, and from there i connect to the HP2620 (also configured as an access)
Do i need to create a trunk in both sides (HP Switch port - Cisco Switch Port) and connect directtly in order to fix this?

Regards,

RE: HP 2620 SW

Yes, a Cisco "trunk" carries vlan tag information kinda like a tagged port does for HP. Trunking a Cisco port will pass all defined Vlans by default; whereas, tagging a HP interface, will only pass the tag you define at the interface. So right now on the HP side the port is expecting tagged info and on the Cisco side, you are not sending it. You have to make both sides match. Trunk/Tag them both, or leave them both access/untagged.

RE: HP 2620 SW

(OP)
Hello, i tried to configured the connectino between the HP and the Cisco like trunk like this

exit
vlan 1
name "ManagementVlan"
untagged 1,5-28
ip address 10.10.1.100 255.255.255.0
no untagged 2-4
exit
vlan 6
name "Phone3rdOffice"
untagged 2-4
ip address 10.10.4.10 255.255.255.0
tagged 25
exit
timesync sntp
sntp unicast
sntp server priority 1 10.10.0.12
spanning-tree
spanning-tree config-name "Office"
spanning-tree config-revision 10
spanning-tree instance 1 vlan 4 6 8 10 12 14 16 18
spanning-tree instance 2 vlan 3 5 7 9 11 13 15 17 19
spanning-tree priority 0

CISCO

spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name Office
revision 10
instance 1 vlan 4, 6, 8, 10, 12, 14, 16, 18
instance 2 vlan 3, 5, 7, 9, 11, 13, 15, 17, 19
!
spanning-tree mst 0-1 priority 0
spanning-tree mst 2 priority 4096

ip dhcp pool PhoneAxF3F
network 10.10.4.0 255.255.255.0
default-router 10.10.4.1

interface GigabitEthernet1/1/2
description Trunk HP Sw
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed 100
duplex full


But i still didnt get the IP for the Phone in the VLAN 6 in the HP, i check some guides from HP they didnt consider configured an IP in the VLAN 6 in the HP i tested with an IP and without but i still get the same result.

Regards,

RE: HP 2620 SW

Ok, couple of things since you did not supply the whole Cisco config. Is your 3750 doing any routing? I did not see the ip routing command, but you could have it somewhere else in your config that you did not supply.

Where is the IP address on the Gig interface you did supply? Your HP is operating only at layer 2, so somewhere upstream, there has to be a next hop for it to to be able to talk to other subnets. I am not seeing that provided nor am I seeing a default gateway on the HP switch.

Hard to see what's going on without the full config of both switches.

RE: HP 2620 SW

(OP)
Hello,

I already manage to fix the configuration in order to allow the traffic from the HP to the core switch.

thank you for your advice.

RE: HP 2620 SW

Please post your resolution as it might help the next person. Thanks.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close