×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Read-only status on tables opened with Foxpro

Read-only status on tables opened with Foxpro

Read-only status on tables opened with Foxpro

(OP)
We have an application written in Foxpro 6.0 that works along with Great Plains Dynamics using Pervasive 2000i.  We use an ODBC connection and are able to retrieve data from Dynamics, but when trying to create a journal entry from Foxpro into Dynamics, it does nothing.  Running the monitor utility during this process, it's showing the tables opened as read-only.  We have checked the ODBC database configuration and it is set to normal open.  We have also turned on the log and the following line is the first error listed.

DIAG [S1C00] [Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface]Driver not capable. (0)

We do have about 12 installations that do work, and this has us stumped.  Any help would be great.

Redeye

RE: Read-only status on tables opened with Foxpro

Could it be that you've come up against your maximum number of sessions/users?

It's been a long time since I worked on Foxpro, but, I was wondering are you using SQL commands to do the journal entries or are you using the x-base update commands?

Do the updates work every time if you execute the commands from the SQL Data Manager?



RE: Read-only status on tables opened with Foxpro

(OP)
I don't think it's a session/users issue.  Generally there are only one or two other users working at the same time and I have tried several times after hours when I am the only user.

We are using the Foxpro update commands to create the journal entries, which has worked for ten other customers with no problems.  

We have not tried executing the commands from Pervasive, we will give that a try and see what happens.

They are running with the most current service packs for Pervasive, Dynamics and Windows NT.  I am logged in as administrator will full access.  

Thanks for your reply,
Redeye

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close