Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


rptapplication server error

rptapplication server error

rptapplication server error

Hi guys,

I am facing the following error when trying to upload the report through CMConsole.

Adding Crystal Report "Account Report.rpt" failed. The server with kind rptappserver returned an error result. Failed to copy the report file to the report object. Refreshing the report object properties might have failed. Failed to read data from report file /app/boe/{8F3F0C22-5D0C-11E1-8A28-002128B736C4}.rpt. Reason: Unable to load report.

I tried to upload BIAR file through Import Report wizard so right at the end after commiting the objects it came with the following error :
Failed to commit the associated files of objects to the file repository server:
(obj ACHAUFileImportStatus, id 9624 ) : File Repository Server error : Could not complete the file transfer..

The environment currently is as follows :
Unix Clustered environment SOlaris 10 (2 box)
Oracle 11.2
I have 2 report application server for each unix box.

please advise,

RE: rptapplication server error

Have you tried saving the report to the server through Crystal?  When you go to File|Save, there's an option to connect to "Enterprise" and save your report that way.


A computer only does what you actually told it to do - not what you thought you told it to do.

RE: rptapplication server error

HI Hilfy,

I cannot save the report through Crystal report as we get this bunch of reports in a biar file to be uploaded.
the Crystal reports sits in a different environment all together so they dont have access to the CMS.

any other suggestions..

RE: rptapplication server error

Well I tried to copy the report to my local server and then opened that report in crystal and tried to save it in CMS, but in vain.

I am able to connect to CMS and view the folders as well but just cannot copy these reports onto there.

what can be wrong..?
the error i get now is :

Failed to commit the associated files of the object to file repository server, COuld not complete transfer

RE: rptapplication server error


I found the solution to my query..

I had to deleted the InputFileRepositoryServer and recreate it through CMS.
After doing this,

I created the directory path for Frsinput and also created a temp directory under it.(TEMP directory was not created initially and i guess you need to have it to make it work)
Same for Frsoutput.

Mentioned the path in the properties of IFRserver and restarted the whole box.

and voila.. - it worked.
hope this might help someone...
thanks and regards

RE: rptapplication server error

In the future, do not crosspost. There are now three unlinked  but duplicate threads in three different forums.


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close