Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

X3500 (7977) "operating system not found"...

X3500 (7977) "operating system not found"...

X3500 (7977) "operating system not found"...

I'm thoroughly baffled... (please bear through my diatribe)

I'm running Windows 2008 Server on an IBM X3500 (7977-AC1). All was working fine and I didn't touch/change anything. A few more details: The X3500 has a ServRaid 8K (<- Adaptec) controller with qty=8 identical IBM HDs organized in 4 RAID sets. BIOS is v1.7.4 (most current) - no unusual lights a-flashin'.

Also new (another problem that has just happened) is an Error 1801 - "No more room for option ROM".

I can get into BIOS setup during POST and all looks fine. I can get into the ServRaid BIOS/setup and I see the (correct) RAID sets with one marked "bootable" (so why doesn't it boot?). The boot sequence remains correct: CD -> USB -> HD (where "HD" = RAID). Lights on the HDs flash during boot (e.g. they are being "acknowledged" and BIOS shows/IDs them all during POST. The "diagnostic panel" on the X3500 that displays a lot of (potential) error via LEDs has none lit. There are a lot of LEDs on the MB and all are green. I can boot from a CD (e.g. run a bootable CD) just fine. Oh yes, the error code for the "operating system not found" is i9990305 if it matters.

What I"ve tried: Re-seating all of the HDs. Re-seating all of the (internal) cards including the RAID card. Re-flashing the BIOS ROM. (I've also tried to disable some PCI "images" to free up the ROM space (?) and eliminate "LAN Boot" from the boot sequence in an effort to fix the 1801 error - neither worked, I still get the no more room for option ROM error - and operating system not found)

Any thoughts/suggestions? It all worked fine yesterday (and for the last two years). I have no idea as "why" but I'd settle for "getting things back to operating/where it was".


RE: X3500 (7977) "operating system not found"...

First - thank you for the (good) suggestion...

Regarding the 1801 "no more room for ROM" error - I truly am baffled (e.g. why is this suddenly happening now?).  I did try to get into the BIOS/setup and disable/restart the "banks" per your link (I tried all six enabled <- normal/default, all six disabled, and three enabled/three disabled).  No luck, I still get the 1801 error in each scenario.  I thought that something (hardware?) might have gotten jostled in the case and hence tried to re-seat everything that I could (e.g. I'm not sure if I re-seated the ROM (where is it?) or if it is permanently wired/soldered to the motherboard but I tried).  Again, it's a mystery as also is the "no operating system found" and indeed I cannot boot anything from the HDs/RAID set(s) (but yet the ServRaid adapter seems to think it is there and bootable).

I also downloaded the IBM diagnostics disk (CD image / bootable) and it seemed to run on all accounts/tests - I didn't see anything tagged as an error.  Also, only entires in the BMI log (or POST log) are my power downs and occassionally no power (when I unplug the redundent power supplies from AC source(s)).


RE: X3500 (7977) "operating system not found"...

About the 1801 error.

There are several workarounds by using F1 BIOS setup that can   

correct this issue:                                             


1. Use the PCI ROM Control to disable the loading of a BIOS     

   Option ROM image. Load only needed Option ROM images and/or  

   prioritize when the ROM image will be loaded and executed.   


2. Change the PCI boot device priority.                         


3. Disable some of the PCI components during boot.              




This is an system architecture limitation.                      


Legacy PC architecture limits ROM image memory space to 128K    

maximum. This limit becomes more of a concern as more devices   

that require ROM space are added to the system. Some of these   

devices may load their images into ROM space by default.        

Additionally, like devices are not able to share ROM space.     


The "1801 No more room for option ROM" message on the screen    

indicates that the system ROM space is full and it has no more  

room for additional adapters which use ROM space.               


A characteristic of some devices is that the image initially    

loaded into the ROM space may be larger than the final image.   

This means that certain devices will require more space when    

they are initially loaded than they will require after their    

initial execution. ROM images with this characteristic should   

be prioritized to execute early in the BIOS process to optimize

the use of the available ROM space.                             


Loading a device's ROM images is required if you plan to BOOT   

or PXE from that device, if not, then loading the ROM image is  


 Also, I would suggest you go to IBM site and search bootable media creator. And update all code on the server.                                                      

RE: X3500 (7977) "operating system not found"...

First - thank you for your suggestion(s).  I thought (incorrectly) that I had pursued that avenue in trying to solve the 1801 problem.  In fact when I disabled the LAN ports in the advanced/boot menu, the 1801 problem ceased.  Hurrah! (I owe you a coffee)

(I have no idea as why this issue should have occurred at this time as the previous BIOS/boot configuration was as such and stable for over two years.  To some extent, I don't care, I'm happy to be beyond that...)

But...  (there's always that 'but')

I still have the 'operating system not found' problem which is getting to be more than disconcerting.  During POST all of the SAS drives appear correctly, going into the cntl-A SCSI setup all RAID sets show properly with the correct set showing as 'bootable', and I ran the (standalone/bootable) advanced diagnostics disc/CD on the HDs without error (all HDs are SAS) and the SAS portion shows no issues with the controller or the physical HDs themselves.  As stated earlier, I physically pulled all of the HDs and ServRaid card and reseated them.

It appears that my system (and me too) is confused.  Is there some way to inform it that indeed there is a bootable/system on SAS drives 1 & 2 which is RAID set X?  

Again, there is nothing(!) that I did that would have gotten near any boot records...  (it was a 'normal' power-down / power-up sans the power-up being successful)

I guess the good news is that I'm past the 1801 problem - indeed I still need help with the system not found issue.

(Thank you)

RE: X3500 (7977) "operating system not found"...

Update -

Perhaps this is a (sudden/unexpected why?) Windows 2008 issue with my boot record being corrupted?  Am about to start a new thread as I'm becoming convinced it isn't the hardware...

Please see X3500 (7977) "operating system not found..." Part-2 for the next chapter in this continuing (and frustrating) adventure.

(Thanks again for the above help!)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close