×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

problem cryptoadm service solaris10

problem cryptoadm service solaris10

problem cryptoadm service solaris10

(OP)
Hi all

I have the following promblem:

I have made a live_upgrade from solaris 9 to solaris 10 in a SunFire 15K. When i boot form solaris10 i see that the svc:/system/cryptosvc:default (cryptographic services) is in maintenance status

Seeing the log i found:

Executing start method ("/usr/sbin/cryptoadm start") ]
cryptoadm: failed to open /dev/cryptoadm: No such file or directory
[ Jun 21 12:58:22 Method "start" exited with status 1 ]


I try to install the Kernel software providers but i cant install it.

cryptoadm list

Kernel software providers:
cryptoadm: failed to open /dev/cryptoadm: No such file or directory
cryptoadm: failed to get the state of a kernel software providers.

 svcs -vx
svc:/system/cryptosvc:default (cryptographic services)
 State: maintenance since Tue Jun 21 12:58:22 2011
Reason: Start method failed repeatedly, last exited with status 1.
   See: http://sun.com/msg/SMF-8000-KS
   See: man -M /usr/share/man -s 1M cryptoadm
   See: man -M /usr/share/man -s 1M kcfd
   See: /var/svc/log/system-cryptosvc:default.log
Impact: 7 dependent services are not running:
        svc:/network/ipsec/ipsecalgs:default
        svc:/platform/sun4u/sckmd:default
        svc:/system/cvc:default
        svc:/platform/sun4u/dcs:default
        svc:/network/ipsec/policy:default
        svc:/application/management/sma:default
        svc:/network/ssh:default



Please anyone can help me to start this service in order to start his dependencies. I try with cryptoadm start/install provider=<provider_name> without result



Thanks in advance and regards  

RE: problem cryptoadm service solaris10

(OP)
Hi all

I solved the problem. I was boot with commands boot and boot -- -r and the problem persist. When i create /reconfigure file the svc:/system/cryptosvc:default  service is online.

Regards

RE: problem cryptoadm service solaris10

Thanks for posting back with your solution, and have a star for doing so!

The internet - allowing those who don't know what they're talking about to have their say.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close