×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Loading CRM in Outlook 2010

Loading CRM in Outlook 2010

Loading CRM in Outlook 2010

(OP)
As far as I can tell, CRM installed correctly. I've installed it the same way on a number of PCs and only 2 (so far) have this problem.

Normally during setup, once it's installed, I open up outlook and it prompts for setup stuff and all is well. For the two PCs that have this problem, there was never a prompt. I go into File > Options > Add-Ins > select COM Add-ins and click Go... > then click on Microsoft Dynamics CRM. The load behavior says "Not loaded. A runtime error occurred during the loading of the COM Add-in".

I've tried reinstalling CRM more than once but that didn't fix it. I've looked at other forums and found similar issues for other Add-Ins (never CRM specifically) and tried all those suggestions with no luck.

Anyone have any suggestions?
 

RE: Loading CRM in Outlook 2010

(OP)
I've been searching the internet and talking to other IT employees here and we found a fix!

Go to C:\WINDOWS\system32 and find mapi32.dll. Rename it mapi32.dll.old then run fixmapi.exe found in the same folder. Restart Outlook then go into the add-ins window and re-enable them.

Hopefully others will find this useful.

RE: Loading CRM in Outlook 2010

Thanks for taking the trouble to post the solution.  What does fixmapi.exe do - generate a new version of mapi32.dll including the newly-registered COMs?

RE: Loading CRM in Outlook 2010

(OP)
I'm not sure what it does with the COMs but it DOES create a new mapi32.dll file. All I really know is that it worked =)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close