×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Unable to open a foxpro 2.6 dbf file

Unable to open a foxpro 2.6 dbf file

Unable to open a foxpro 2.6 dbf file

(OP)
When I try to open and browse a foxPro2.6 for windows dbf table it is giving an error. It says 'File FEJ.PRG' does not exist'. Any ideas on how to resolve this error. So far I have been opening these dbf files which are part of an application with out any problems. This is what I have been doing-
1.Copy the folder containing teh datafiles on to local drive
2. open the FoxPro 2.6 for windows software
3. Then select 'prceed to Foxpro Menu system and command window" option
4.The select file Open and select the file
  This is the command I see in the command  window -
  USE d:\MyTemp\abc.dbf SHARED ( I tried ExCLUSIVE also)
5. then I selct browse option under Database menu
6. At this point I get this error 'File FEJ.PRG' does not exist'

Any help is appreciated.

Thanks


RE: Unable to open a foxpro 2.6 dbf file

Do you get the same thing if you type these commands in the command window?  If so, maybe your installation of FoxProw is goofy (the menu selection is not getting executed properly).  You may need to reinstall.

USE d:\MyTemp\abc.dbf SHARED  [Enter]
BROWSE  [Enter]


Dave S.

RE: Unable to open a foxpro 2.6 dbf file

HI
WHat you are specifying is not leading to find the causes of the error.. tough it is clear that you are trying to browse which is invoking FEJ.PRG

This means, you are using BROWSE LAST.. which contains a filter .. may be a key whatever related to FEJ.prg.

Resolution..
1. You can try and locate the file.. FEJ.PRG in another users computer and copy it.
2. You can try and locate the same in the Network and copy that.
3. After everything... insted of using Browse from the menu.. issue the command in the Command Window.. BROWSE..
4. OR...............
you delete FoxUser.* file in the temporary directory, then the FoxUser.* in the FoxPro directory. This will remove the Browse LAST as well and along with it the references to FEJ.PRG. (most likely)

This shall provide you the relief . If not please post with little more of details like.. is it working in another unit.. etc.

ramani
(Subramanian.G),FoxAcc, ramani_g@yahoo.com

RE: Unable to open a foxpro 2.6 dbf file

(OP)
Thanks Dave and Ramani. Dave's solution and Ramani's resoultion # 3 are same and it worked. I couldn't find the FEJ.PRG on the netwok. Last evening after posting this question on tis forum I tried to make a copy of abc.dbf file and I was able to do that and tehn I was able to browse he copy of the table abc.dbf.
Thanks a lot for your quick resolution. I do not work on FoxPro but I sure will remember you all and will comeback to this forum.




Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close