Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here




I am facing a problem that suddenly that a window pops up saying Java Platform SE binarying has stopped functioning. It gives me two options, either to look for it on the internet or close the program. I have tried both but it stills comes up againg.

The deatil window explains is a APPCRASH hehand the program name javaw.exe. It is apparently a file from Java, I have reinstalled Java that didn't help, so I removed Java from my laptop and it stills pops up.

I have ran my antivirus and antispyware prorgrams, but it hasn't help stopping this window and recovering my browsers, even they found some items.

Further my other browsers Firefox and Opera are not functioning at all, I can only use IE9.
Any helps are highly appreciated.


This is the message that comes with the pop up window:

Problem Event Name: APPCRASH
 Application Name: javaw.exe
 Application Version:
 Application Timestamp: 4ad19f35
 Fault Module Name: ntdll.dll
 Fault Module Version: 6.1.7601.17514
 Fault Module Timestamp: 4ce7ba58
 Exception Code: c0000005
 Exception Offset: 0003bc42
 OS Version: 6.1.7601.
 Locale ID: 1030
 Additional Information 1: 0a9e
 Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
 Additional Information 3: 0a9e
 Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


Exception Code: c0000005 very often turns out to be an access permissions type of problem, but there could be other causes too.

Use the Vista instructions in this to reset to default the security settings if your user is not getting the correct access.

Test with another, or a newly created user, see if they get it installed or running.

How do I restore security settings to the default settings?

If you look in MsConfig you might find some Java applications in there which run at startup.

Try right-clicking on the actual Setup.exe and selecting the "Run As Administrator" option?  Do so even if your user is an Admin.

This example might or might not work for you with your program it uses the built-in Administrator account to perform the install?

"It seems that the "Run as administrator" command only gives you some administrative privileges, and they're not enough to install Java (and OpenOffice, by association). In order to get around this, you need to actually log into the built-in administrator. Open a command prompt with admin rights by clicking start, typing cmd into the search/run box, and hitting CTRL-SHIFT-ENTER. At the prompt, type:

net user administrator /active:yes

Then log out of your regular account and back in as the built-in administrator, where you might be able to install the program. When you're done, log back into your regular account and, for security purposes, disable the built-in administrator account using:

net user administrator /active:no "




when does the the error window pop-up? (e.g. when you start the laptop, or when you start a certain application?)

and yes, the JAVAW.EXE is a part of Sun's Java Runtime Environment, it gets called by Java apps, and when they cannot find the path to the program, then that error message gets put out...

so in order to fix that fault, we will have to identify which java program is causing the issue...

"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"


The pop up windows shows almost every 5-10 seconds, if I close it, if I leave it to be open then it just remains open on the screen. This pop up shows up whether I start a program or not.

I will follow those guides you mentioned and come back with the results.


I have found this page claiming that they have the solution for reparing this problem I am facing.


They mean after running ReimageRepair.exe it will solve the problem. My problem is that I can not install this program, as it gives me a notation that the firewall won't allow this. I have added this installation file in firewall and it still can not install.

Any suggestions on how to remove blocking this program in firewall?

There is one other thing I wanted to mention that, when I run the Ccleaner to remove the unnecessary registries, it shows a long list even though I have already cleaned the registry. Is there a connection between this and the problem I already mentioned?



I took a look at the program... lots of stuff that it does to the PC... e.g. proxy settings, downloads programs from the internet, registry changes... got me leery as to what the program actually does...

now it claims to replace faulty files with clean ones, downloaded from their servers and ...


we're 100% sure the repair will fix any problem you have - or your money back!
ah, I see they expect a payment for fixing stuff that may or may not be faulty... hmmm...
if you want to replace faulty files with non corrupted versions, for free that is, and guaranteed to work, the by all means do an Inplace Upgrade Install also known as the proverbial REPAIR INSTALL...

How to Do a Repair Install to Fix Windows 7

but before you do, a little test first, try it with UAC turned off, to see if it is just a darn permission fault or not...

also doing a full AV and AntiMalware scan and a MEMTEST first would be in order...

"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"


Thats exactly what I thought that one program can do so much.
I just made a complete cleaning for spywares on my laptop and it seems that Java message is not apperaring as it used to. I guess there were some malwares that caused the problem.

However I am still stuck into why my other browsers except internet explorer 9 are not working. Firefox starts but it does not show any pages, even the start page, Opera and Google chrom do not open at all. My guess is an interruption from internet explorer 9.
Could this be the reason?


I have tried those programs you mentioned, plus some other, they have caught some malwares but it didn't help to solve my problem.
I have used a different user account, but it gives the same problem.
I have tried to enter the safe mode in Firefox but I can not enter it. It doesn't react to anything.
I have installed the Safemonkey browser and it gives the same problem as other browsers. The only browser that works for me in Internet explorer, have tried it with both version 8 and 9.

The Java pops up window comes rarely, I have also installed the Java Run time 32 bit.


You might try K-Meleon browser as a workaround. I do think this could be related to damage left by a previous malware though.

A visit to a good malware removal forum to run their recommended diagnostics and possible repairs or a Windows repair install might be in order.

Did you test what happens from a newly created User profile?



have you attempted to uninstall FireFox and then fresh installing it?

to see if it is the winsocks that may have gotten scrambled, open a CLI (Shell, DOS Box) (Start >> RUN >> CMD >> [ENTER]) and type the following and restart when prompted to:

netsh winsock reset catalog

once rebooted, test FF again...

you may try to see if there are any system files that are corrupted or damaged, in that you open a CLI again and issue the following command (have your Win7 DVD at hand):

sfc /scannow

and then retest again...

but in the long run, I would think that it would be more prudent to just go ahead and install Win7 again from scratch, just be sure that you have all your data saved to another drive (USB, eSata, or internal HDD)... imho...


"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"


I have tried to reinstall FIrefox as well as other browsers but nothing happens.

I recently removed PC tools FIrewall from my laptop but I see that the folder still remains and its not possible to remove it, even though the program has been removed, its only a folder containing around 200 mb files.

Could this might be that is causing the problem?


The program I removed is PC Tools Firewall, and not PC Tools Security. But the folder that is remained under Programs are named as PC Tools Security.



Can you reinstall that PC Tool firewall and then uninstall it again,  and if it has its' own uninstaller, try right-clicking on the actual uninstall.exe and selecting the "Run As Administrator" option?  Do so even if your user is an Admin?  It then might uninstall the program correctly from Program Files and from the Registry.



I managed to completely remove PC Tools Firewall from my laptop, but the problem still remains.
I have even installed other browsers but none of them are working except IE8.  


Is it time to consider the repair install, or a clean install, solutions, after saving your valuable data?

You can try these first.

How to repair the operating system and how to restore the operating system configuration to an earlier point in time in Windows Vista (or 7)

How to analyze the log file entries that the Microsoft Windows Resource Checker (SFC.exe) program generates in Windows Vista

How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

Anything in the Event Viewer?

Working with Vista's new Event Viewer


Try running ChkDsk to check your drive for errors. Right-click your Drive icon/ Properties/ Tools/ Error Checking.  Try it first by not checking either box (this will run it in a Read-only mode) to see if it flags any hard drive or file problems.  If it does, restart  it by ticking both boxes, and rerun it to allow it to attempt to fix any found problems.


thanks for those tips you mentioned, I have tried them both chkdsk and sfc command, they didn't show any errors. The laptop is only a month old and I am not sure whether it needs a fresh installation yet. But I'll wait a bit longer to see if I can find a solution to help me use the other browsers.  


I can't help thinking that the hiccup with PC Tools has perhaps upset something that is preventing access via your other browsers?

Is IE using Proxy Server settings in the Tools/Internet Options/ Connections/ LAN Settings?

Is any Router Firewall interfering with the other browsers?  What if you try disabling any such Firewall if it is enabled?


IE is not using any proxy servers.
There is only the Windows firewall on the laptop.
I had previously installed the PC Tools firewall, and removed it as it always came up asking for giving permission to programs I already had given permission too.  


I was wondering if its a good idea to replace the ntdll.dll file with a fresh one, as I see this appears when I want to start Google chrome.

Does anyone know where I can get this file from a reliable place?


The System File Checker would have checked ntdll.dll for you and replaced it if it was faulty.

The file would be obtainable from any other working machine of the same edition and version of your operating system.

Have you updated to SP1 yet, removing or installing SP1 would give you a new copy of the file I imagine?

Otherwise searching for it online is an option, just how reliable such a file would be is anyones guess.

These are the details of my file on Windows 7 64-bit Ultimate.

ntdll.dll    C:\Windows\System32    1,292,096    20/11/2010 3:24:36 AM    23/02/2011 3:11:06 PM    16/04/2011 9:33:22 AM    A    dll


The Windows on my laptop was preinstalled and I have my Windows updated to SP1.
The ntdll.dll in my system has a size of 1,731,936 byte (which is somehow bigger compared to your file), with version: 6.1.7601.17514.

I have searched the Google and it seems that there are others who have faced problems with this dll file, and has caused crashing softwares like IE.

I found this site which gives some explanations about this file,


I will see what it comes up after I update my drivers and reply.


I consider that site and the hundreds of others punting out Regcure to be written by forum spammers and crapware sellers.


I think the problem is solve now.

I have uninstalled all the browsers on my laptop except for IE 8, and installed the Minefield, instead of Firefox 4. Now both these two browsers are working well.

I guess the problem started after updating the Windows 7 to SP1, as I remember Firefox 4, Opera and Google chrome worked well until I updated to SP1. And I am no longer receiving any APPCRASH for any files or programs,.... at least so far.


SP1 is NOT the problem. I also have Windows 7 installed with SP1. I also have IE9, and fF4 installed. Both work without problems. I had chrome installed, but do not like it at all, so removed it.

IF the problem comes up again, I would re-run chkdsk with the /R option. It does some other things as well.  I would also go thru the system registry MANUALLY and remove entries from programs you've un-installed.  Then do a defrag. My not solve the problem, but can't hurt.  AND if all that doesn't do you any good, I'd back up my data, and then re-install the OS. Yes, I know it's a lot of work, but in the future may be the only way to really fix the problem.


@PRPhx: mach04 didn't say that the problem was SP1, only that the problem started after he'd installed it.


I did run a chkdsk/r once again, and it didn't find any failures. I am still unable to use FF4, Opera and Chrome, and it teases me why its happening.


The program I used to check the size appears to be in error, the Windows Properties also shows the size of my file as 1.65 MB (1,731,936 bytes).

Did you ever check with a different user to see if the problem still occurred?


I have tested by creating different users and it makes no difference at all. Other browsers are not working at all, as they used to in the beginning I bought this laptop.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close