×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

safeboot has been corrupted (error 92h)
3

safeboot has been corrupted (error 92h)

safeboot has been corrupted (error 92h)

(OP)
Hello,

i am encounter the same problem which is described in the following thread (thread1726-1576191: Bitlocker: safeboot has been corrupted (error 92h)).

My disk :
partition c: system (not encrypted)
partition d: data (ENCRYPTED)

I got this error (subject of this thread) after doing an image restore of the partition C with Acronis image.

I tried for one week to understand the origin of the problem, i found that the safeboot program is install in the pre-boot (sector 1 to 63) of the disk.
The thing is when i restored the image on the partition C, it seems the files (safeboot.sys and safebot.rsv) are moved.   That means the pre-boot point to those file.

I already have my key recovery but i can't even load the safeboot to use it.


So i have two question :

1) does anyone have a url link to download the SAFETECH soft ?  
2) DOes anyone tried to find the accurate offset which point to SafeBoot.fs or/and SAfeboot.rsv ?


Thanks you guys

P.S : i need my data back, as everyone does.

 

RE: safeboot has been corrupted (error 92h)

2
I don't pretend to understand what you are talking about, everything I look at on this problem links to McAfee, are you using any of their products?


How to create a SafeTech boot disk for Endpoint Encryption for PC 5.x and export the User and Computer configuration
https://kc.mcafee.com/corporate/index?page=content&id=KB53257

How to use the SafeTech Disk to remove the encryption and boot sector from the hard-disk
https://kc.mcafee.com/corporate/index?page=content&id=KB61119


Stuck in recovery !!!
https://community.mcafee.com/message/143548


Can your hard drive be easily removed from this machine and placed in another machine in order to allow you some type of access?

RE: safeboot has been corrupted (error 92h)

(OP)
thank you linney for your reply.
first, i can remove my disk from my laptop and place it somewhere else.

The fact is i use HP laptop (6510b) which use HP protect tools. The encryption system is based on SafeBoot.

Now, i needed to restore my system c: with an "acronis image". After this restore, i got this message error.

So, i made a bunch of test with another DISK (identical to the firlst one) to see if i could resolve the problem.  

Here are my conclusion :

1) the acronis true image server do not write any bit on MBR and the PRE-boot.  it just restore the partition.

2) The safeboot software is loaded from the pre-boot (62 sector)

i think that the image i created corrupt the file (safeboot.fs and safeboot.rsv)

so my only solution is to use the link you sent, but i don't find how to download the safetech.exe    

that is all i need i guess.

 

RE: safeboot has been corrupted (error 92h)

Like I said, it seems to be part of McAfee software, so you might have to download or purchase that containing software?  If you already have the software you should have that program already, or it is being used by HP Protect Tools under some sort of license deal, or as a similar type program designed by HP?

So my question to you is do you have the McAfee tool, or the HP Tool already installed or loaded on this machine?

Sorry to sound vague, but this is something that I am learning about for the first time.

Have you talked to HP, or looked at the HP Forums to see what HP Protection Tools do and how you can repair or recover from what they do?

where to start?
https://community.mcafee.com/thread/34424

Safeboot.fs found more than once
https://community.mcafee.com/message/3900

Operating system not starting!!?
https://community.mcafee.com/thread/1244?tstart=-22

I was also thinking about programs like this and whether they are of any use.



MBRWork 1.08
http://www.terabyteunlimited.com/downloads-free-software.htm

Updated 1/24/2010

"MBRWork is a utility to perform some common and uncommon tasks to the MBR/EMBR sectors of a hard drive. It should only be used by power users who understand how computers work. The readme.txt file in the ZIP contains a list of the tasks available".

Have a look at the Readme file.




 

RE: safeboot has been corrupted (error 92h)

(OP)
good morning,
well i do have the HP Tool.  McAfee bought recently the Safeboot company and included it to their product ENdpoint Drive Encryption.

So i may purchase that containing software. Because th HP tool do not include the SAFETECH software.

I already talked to HP support. And honeslty, they are useless. after two hour of chat, they said, "this problem come from safeboot". well great, how do i resolved this issue ? ... dead silence..

Concerning the link you sent, i already read them. In the thread 1726-1576191, posted in this forum, the user seems to resolved the problem. so i just need to get this Safetech.iso .

anyway, i will have a look on MBRWORKS and keep you informed. But i confirm that my problem is not related to MBER or to the "Partition gap" (pre-boot).   I made some test by comparing those sectors, before and after installing   Hp protect tool and activating the encryption drive.


c u

RE: safeboot has been corrupted (error 92h)

(OP)
hello again,

i just saw the possibility of MBRWORKs, and unfortunatly, i already did manually what this soft do with EditHexa. smile


who wants to know my feeling right now ? ??  sad(((

RE: safeboot has been corrupted (error 92h)

What is this site offering?  Is there anything relevant in their downloads?
http://dpms2.com/tools

RE: safeboot has been corrupted (error 92h)

(OP)
great link.  i download the Safetech product, then burn the iso and boot from the CD.

This software for the auhorized "day code" and the authenticated part.

I took the day code from this thread "1726-1576191" which is good. (thank you woter324).   Nevertheless, i still can't authenticate.

If i follow the folowing link, i need a machine configuration file (.SDB) file (which i don't have) : https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/22000/PD22214/en_US/WinTech%20and%20SafeTech%20Administration%20Guide.pdf

I already read this one too :
https://kc.mcafee.com/corporate/index?page=content&id=KB68084&;actp=search&viewlocale=en_US&searchid=1302522555998

but no success.

This situation is weird.  I have the recevory KEY (.dat), my disk is sane, and i can't recover my data.

pffffff

RE: safeboot has been corrupted (error 92h)

(OP)
OK i did it.  finally.

First, i want to thank linney for his help and for this precious link.

Here are the following procedure for that issue :
(this procedure only works if you have the recovery key). without it, you won't recover anything.

1) download the wintech/safetech .iso file, burn into a cd and boot from it
2) choose the second Option (WiNTECH)

3) once the system booted, go to menu--> program--> Safebootwintech
4) enter the daycode 1131 which is valid only for a system date (27/10/2009) . Then you will be authorised to use it

5) then go to the menu and choose "Wintech" --> Authenticate freom authenticate From HP recovery FIle (.dat extension)

6) Finally , go back to start Menu , then --> Programs,--> A43File Management Utility

--> Then you will access to your data.  Don't forget to plug another USB drive before starting the WINTECH CD, then you will be able  to copy your data.

The copy process concern in decrypting the files and copying them.


Thank you agin Linney. it's been 12 days i am working in this issue.



 

RE: safeboot has been corrupted (error 92h)

I'm glad that you have solved this issue finally, and thank you for the feedback and kind comments.

I never use "whole drive" encryption myself, but sometimes might encrypt a small amount of data in a specific location, I just don't have the need for it with what I keep on a computer.  Another reason, as you have found out, is that when encryption goes wrong it becomes almost unsolvable.

I shall keep this thread handy in case it pops up later down the track. I'm sure it might benefit a few more HP users.

What are you yourself doing about your backup regime and Acronis, do you still  think Acronis was the initial cause, and do you think that your problem might occur if you changed your backup and restore regime?

RE: safeboot has been corrupted (error 92h)

(OP)
Actually, i have never been disapointed by "Hp protect tools" and its "safeboot".
If you backup the recovery key and put it in safe place, there is no reason you won't retrieve your data, unless a crash disk.

The problem is the lack of information from HP, McAfee, and Safeboot. WHen McAfee bought SAfeboot, the only support was Mcafee. And as you can see, it wasn't easy to get their toolkit (safetech/wintech), and their day code.

I even tried to locate with the help of HexEdit, the accurate offset which point to safeboot and set it to the partition gap. with no success.

As far as it concern Acronis, i don't ant to point it out. Acronis do raw image, but it seems not compatible with Safeboot. There is two safeboot file (safeboot.fs and faceboot.rsv) which has been not copy properly. Acronis registered an issue like mine, but didn't give any solution.

In the future, i will keep using hp protect tool and safeboot, and i will keep in a safe place my recovery key + wintech /safetech, in case of smile. The only thing i won't use is Acronis.

my backup regime was about (1 system acronis image)/month and a simple ntbackup/week.  





 

RE: safeboot has been corrupted (error 92h)

1) download the wintech/safetech .iso file, burn into a cd and boot from it.


Please provide the link of the download page from where we can get it...

Thanks a Lot.
Vijay

RE: safeboot has been corrupted (error 92h)

Thank you guys, especially Linney, for the link.

I wiped my MBR and only had the .dat file. My partition that was encrypted was intact.

I used the Wintech software to identify which sectors (start & count) were the encrypted. Then use Workspace to open a some of the sectors and decrypt them to ensure I have the right key. If open the first sector alone and decrypt with the correct key you will see the NTLDR is missing message.

I then Force Decrypted all of the sectors. 180GB took 23 hours.

Then using A43 file explorer moved them over to a USB HD.

RE: safeboot has been corrupted (error 92h)

It's important to add that although I wiped my MBR a new one had been created by a W7 installation. The MBR needs to be correct if you are to correctly identify the partion sectors. A good check seems to be the first sector as it contains the NTLDR error message.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close