×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Print SAY and Memo Fields Together Report Writer.

Print SAY and Memo Fields Together Report Writer.

Print SAY and Memo Fields Together Report Writer.

(OP)
Hi Fox Friends;

Ran into this bit of ugly yesterday. I have a report with 2 SAYs (Label) and 2 memo fields. I want to associate the SAY with the first line of the memo field. The memo field is defined as "float". In the report writer it looks something like this....

Desc1        MEMO1

Desc2        MEMO2

But when it prints, it looks like this.

Desc1        MEMO1
             MEMO1
             MEMO1
Desc2        MEMO1
             MEMO1
             MEMO1

             MEMO2

Anway around this?
TIA - Wayne  

RE: Print SAY and Memo Fields Together Report Writer.

Not unless you can predict how many lines the memo is going to occupy, since the memo floats but the label doesn't.
You could try adding the label to the memo and see if you like that.  In the expression builder, do something like:

"Desc1 " + Memo1

Of course, it will occupy the same space but it might do what you need.

Dave S.


RE: Print SAY and Memo Fields Together Report Writer.

HI
1. May be you have to use ALLTRIM(MEMO1)
2. Also, if the DESC1 space is not enough, make sure the width is sufficient. Otherwise combine bot the fields and have DESC1+" "+ALLTRIM(MEMO1) and have a long field, if that helps.

ramani
(Subramanian.G),FoxAcc, ramani_g@yahoo.com

RE: Print SAY and Memo Fields Together Report Writer.

Hi,

In the report writer that simply shouldn't happen. Verify:
* Double clicking MEMO field -> Relative position -> Above-variable height field checked,
* Double clicking DESC field -> Relative position -> Above-constant height field checked,
* Double clicking DESC field -> Relative position -> Above-constant height field checked,
* Double clicking detail band -> constant height band not checked,

Hope this helps!

David.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close