×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

New language evironment in Solaris 9

New language evironment in Solaris 9

New language evironment in Solaris 9

(OP)
Hi,
I'm a dummy in SUN! Well, I've to install a new language environment.
That must be: de_DE.UTF-8, de_DE.UTF8@euro.

The machine it's a SPARC proc. in a 64-Bit environment.

I've looked in internet and found the package "SUNWeu8ox" for UTF-8 for the American English. That would be ok, too I think!?
But if I go to the current package on the CD Medium (/cdrom/cdrom0/Solaris_9/Product/<package>) and want to start with:

#pkgadd -d SUNWeu8ox

the error "no packages were found" occurs.

Why? I don't understand! I've used the CD 1 of 2 CDs. I wonder that there is a special language CD avaiable, too. For what?
For UTF-8, it's only this package I've to install? What's the different between "OS Environment User Files" and "Environment User Files". (for each one a separate package)

Thanks a lot for your help!

Kind Regards
Oliver

RE: New language evironment in Solaris 9

try -

#pkgadd -d ./SUNWeu8ox (After CD to the correct directory)

or

#pkgadd -d /cdrom/cdrom0/Solaris_9/Product/SUNWeu8ox (from anywhere)

Steve

RE: New language evironment in Solaris 9

(OP)
Hey Steve,
thanks for the info! Well, suddenly it was working like you said smile But another thing ... do I have to reboot the machine if I've installed and export a new language environment at all? I've already added an entry in the /etc/profile file.

Thanks & Regards
Oliver

RE: New language evironment in Solaris 9

(OP)
Hello Gys,
well, anyway I've installed the english UTF-8 package.
The strange thing is, that the machine gives me a warning of the current timezone. Is it equal, or should I've take care of that?
How can I takeover the parameter as a global setting for the system? I've to set LANG and CTYPE Parameter to UTF-8.

The current output is:

# locale
LANG=POSIX
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES=C
LC_ALL=
# locale -a
POSIX
C
iso_8859_1
iso_8859_15
en_CA
en_CA.ISO8859-1
en_US
en_US.ISO8859-1
en_US.ISO8859-15
en_US.ISO8859-15@euro
es
es_MX
es_MX.ISO8859-1
fr
fr_CA
fr_CA.ISO8859-1
en
common
en_US.UTF-8

Where can I download or find the german UTF-8 package?

Thank you a lot!

Kind Regards
Oliver

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close