×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Reconciling SMB-Linux share names with Windows

Reconciling SMB-Linux share names with Windows

Reconciling SMB-Linux share names with Windows

(OP)
How do I "fix" the long drive names displayed in local workstations (WinXP) "My Computer", so they agree with the data in my smb.conf file and Linux "smbclient -L" displays?

Problem:
I'm running XP workstations under a SMB 3.4.0 domain server called JAM.  Shares seem to be operating smoothly, but the "drive naming" under WinXP clients is different.  Look at the samba shares from the server...

CODE

root@jam:~/samba# smbclient -L smb
Domain=[JAM] OS=[Unix] Server=[Samba 3.4.0]
 Sharename       Type      Comment
 ---------       ----      -------
 netlogon        Disk      Network Logon Service
 app             Disk      app samba share
Yet the info displayed in WinXP My Computer is different:

CODE

NAME                                                   COMMENT
 app on 'jam server (Samba, Ubuntu) (smb)' (I:)
 netlogon on 'jam server (Samba, Ubuntu) (smb)' (N:)
It looks to me like the names are getting generated by the old default "server string" variable from orig.smb.conf:

CODE

server string = %h server (Samba, Ubuntu)
But in /etc/samba/smb.conf I have reset that string to

CODE

server string = "hello"
...which displays correctly under smbclient -L

CODE

  Server               Comment
  ---------            -------
  SMB                  hello
Why am I getting share-names under XP derived from a "server string" syntax that's not even in my smb.conf file?  I've grep'd "(Samba, Ubuntu)" and it doesn't appear in /etc/smb.conf or any samba configuration file I can find (other than un-used original versions).

I'm stumped!

RE: Reconciling SMB-Linux share names with Windows

(OP)
Okay, today I see my drive names are changed.  After some experimenting, in the windows Registry, I found this key:

CODE

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\ComputerDescriptions
containing a list of machine names.  When I reset the name of my SAMBA server to null, the new string "hello" that I configured in smb.conf propagated to the drive names in My Computer.

So is this a winbind problem?  
Is there some way to "force" the names to propagate faster?
Do I need to restart winbind along with /etc/initi.d/samba?
If so, before or after?

RE: Reconciling SMB-Linux share names with Windows

I think it's a Windows issue.  It might refresh if you delete the drive mapping and add it again with the net use command.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close