×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Samba .conf / file permissions

Samba .conf / file permissions

Samba .conf / file permissions

(OP)
I've got an ubuntu server(10.04) setup, and I've mapped a network drive on my laptop(Vista) to to it. I use it as a web server to test out local websites and php code.
Everything works fine except I have to use the chmod -R on each folder I create to allow file permissions to save, upload etc. I cannot use the security tab in the properties menu remotely from my laptop.

The user I use on the server is andy, i.e. andy@server:~$ and in the security tab I see in the Group or Username box:
Everyone
andy (Unix Group\andy)
andy (ANDY\andy)

ANDY is also in my network folder along with ANDY-LAPTOP, both in the work group HOME.

I'm assuming it's something to do with my smb.conf file which is in /etc/samba/ (is that where it should be?) Samba version is 3.4.7

Here is what is in my smb.conf file that is not commented out:

[global]
    netbios name = andy
    workgroup = HOME
    security = user
    null passwords = true
    wins support = yes
   
[MyFiles]
    path = /var/www/
    browseable = yes
    read only = no
    guest ok = yes
    create mask = 0777
    directory mask = 0777

The /var/www/ folder is what my server folder on my laptop is mapped to.
I want to be able to give Everyone full control from my laptop. Is there something I'm missing or doing wrong?
Cheers for the help.
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close