×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

switch from multi usermode to single user mode error

switch from multi usermode to single user mode error

switch from multi usermode to single user mode error

(OP)
i tried cahnging my solaris system mode from multi usermode to single usermode using command init -S. when it reboots, it shows successful that it has been change to single user mode but computer tells me about control-d, login as remote user, then advised me to choose y or n to open window, when i log in as root, it gives me this dt error

The DT messaging system could not be started. to correct the problem
1. choose ok to return to the login screen
2. select failsafe session from login screen option menu and login
3. check to see hostname is correct in these location
   a) /etc/src.sh
   b) /etc/host
   c) /usr/adm/inetd.sec

Question, how would i know if hostname is correct or not and how would i know what is my hostaname?

4. check to see magic cookie related error messages in these lcocation /var/adm/messages
or $HOME/dt/errorlog

i am not yet familiar with this config,maybe someone can help me understood it better as in laymans term? im still a beginner...

RE: switch from multi usermode to single user mode error

Your hostname should be shown if you issue a uname -a command (it's the second item in the list).

The internet - allowing those who don't know what they're talking about to have their say.

RE: switch from multi usermode to single user mode error

(OP)
it says
SunOS BDL09493A4 5.10 Generic_138888-07 sun4v sparc  SUNW, SPARC-Enterprise-T5120.

so my hostname is BDL09493A4? correct?

as i cat the letters a-c in checking correct host location, there is an information only in  b) /etc/host for the hostname, a and b dont have.  but under this file someone added (BDL09493A4_1) though there is an existing hostname BDL09493A4, i think someone is trying to add another hostname

so this is incorrect right?

as for /var/adm/messages or $HOME/dt/errorlog i do not know how to know if there is an error, i can see hostname and it is correct

 

RE: switch from multi usermode to single user mode error

Yes, your hostname seems to be BDL09493A4. What happens if you ping BDL09493A4? ifconfig -a should give you information about the network interface card, including it's IP address.

The internet - allowing those who don't know what they're talking about to have their say.

RE: switch from multi usermode to single user mode error

(OP)
if i ping BDL09493A4 says its alive,
if i do ifconfig -a it shows
lo0: flags=201000849<UP, BROADCAST ,MULTICAST . IPv4, VIRTUAL > mtu 8232 index 1 inet 127.0.0.1 netmask ff000000
e1000g0: flags=201000803<UP, BROADCAST ,MULTICAST . IPv4, CoS> mtu 1500 index 2 inet 10.203.206.27 netmask ff000000 broadcast 10.255.255.255 ether 0:21:28:5d:7e:a0
e1000g1: flags=201000803<UP, BROADCAST ,MULTICAST . IPv4, CoS> mtu 1500 index 3 inet 10.203.206.28 netmask ff000000 broadcast 10.255.255.255 ether 0:21:28:5d:7e:a1

wherein data are the same with when i do command cat /etc/hosts, shows

127.0.0.1       local host
10.203.206.27   BDL09493A4    BDL09493A4.tmp.domain.net loghost
192.168.1.1     cmssvr-c
192.168.1.2     cmssvc-c
192.168.2.2     switch
10.203.206.28   BDL09493A4_1
10.203.206.133  buck_pbx

may i ask, what is the relation of dt error when changing multi usermode to single usermode?

maybe this info would help, my cms server is not connected to any router or pbx just lan connection to from ethernet0 to my laptop which has cms supervisor, and i can connect both only after i set the server to
ifconfig e1000g0 inet 192.168.1.5 netmask 255.255.255.0
and it works...

i am really desperate to know.. there are a lot of technical terms which i dont know and its importance...and i really appreaciate you KenCunningham answering my question... thanks






 

RE: switch from multi usermode to single user mode error

Sorry, I'm not particularly familiar with the dt message, but have you checked the 'magic cookie' stuff as mentioned in 4 above?

The internet - allowing those who don't know what they're talking about to have their say.

RE: switch from multi usermode to single user mode error

(OP)
yes, and i tried searching for error but didnt show any error. my computer cannot successfully login to single user mode. when i click on ok, it reboots but i have a gray screen only and i cannot operate the server. good thing i have telnet and putty access, i only type command: boot -s then it reboots my system correctly but goes back only to multi usermode 3... =(

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close