×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Lotus Approach not keeping changes

Lotus Approach not keeping changes

Lotus Approach not keeping changes

(OP)
I have used Approach for years, at work and now as retired and building large rosters of Veterans (www.IndianaMilitary.org).  Everything was going fine, but suddenly it stopped remembering changes.  Either individual changes or Find/Replace changes.  It appears to take them, and make the changes, but when I go back it has reverted to the old info.  I completely removed the software and re-installed.  I know that worked as I now have to browse for the files the first time.  But same problem.  Thought I'd switch to some other free database, but they are impossible to work with.  Apparently made for programmers instead of users.  I need my Approach to work properly.  It does the same with any of my 8 databases.  Sure will appreciate any help.

Jim West

RE: Lotus Approach not keeping changes

Hi Jim - Sounds frustrating. I too am a user of many years, yet to find an alternative that meets my needs as well as Approach has sad

Not knowing what you've tried - or your level of expertise - but have you tried ruling out possible (obvious?) causes - e.g. that the .apr view file is in fact attached to a different .dbf than you think it is (assuming you are using the default) data file ? You could try opening the .dbf file concerned directly (select file type to open DBase IV and it will display those )and writing data to that file direct. Ensure it works there. Obviously be careful not to simply do a "save" over any .APR file by the same name - which Approach will prompt you to do. You could also try creating a simple/basic .apr file that way and see if data edits are saved.

Secondly, I assume you are using data that is stored and accessed locally on your own hard drive (so we can rule out any Internet read/write protocols and issues ?

Thirdly, (on a similar note to 2) I guess it's worth revisiting exactly how Approach 'writes' data changes to the data file. What I do know from experience is that, despite what one has supposedly 'entered' in say an .APR form, if one presses "escape" any changes that may have seemed 'entered' changes are lost. Which indicates that is that changes data is not actually 'written' (to the disk) until one has tabbed or moved on to another record and/or 'forced' a data 'save' e.g. by used the carriage return looking Smarticon.

Anyway, just some ideas from a non-expert. Hope it helps, but either way - best of luck. Tim
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close