Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Cool Ice GateTool Not working from Desktop

Cool Ice GateTool Not working from Desktop

Cool Ice GateTool Not working from Desktop

Hello out there, Need some help with the ICE Gateway Configuration Tool.

I am getting the follow message when trying to access the gateway tool from my desktop.

Java Plug-in 1.6.0_18
Using JRE version 1.6.0_18-b07 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\winne
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>

load: class CIAdmin.class not found.
java.lang.ClassNotFoundException: CIAdmin.class
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed:http://someurl/cisystem/gatetool/CIAdmin/class.class
    at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    ... 7 more
Exception: java.lang.ClassNotFoundException: CIAdmin.class

I also tried in firefox and chrome and it looked like it was going to work, but just sat there saying loading configuration and never got past that.

I tried clearing cache, and deleting temporary internet files according to https://www.support.unisys.com/mapper/docs/bis10.1/chm/78502671-007/78502671-007.chm documentation.

I am currently running Windows XP svc pack 3, IE 8, Mozilla 3.10, Chrome 6

Any help would be appreciated.

Note: I am able to get the gateway tool to work from our test box running IE 6, but it would be nice to get access to it from my desktop.  Not sure if this is just a Java version issue or what.


RE: Cool Ice GateTool Not working from Desktop

I think we have figured this one out.  It seems that the gatetool will only work if running as "Administrator".  
Just an FYI in case anyone else runs into this.

RE: Cool Ice GateTool Not working from Desktop

In the past I have run into something simular to this. My problem is that I could not get the GateTool to run on the server but had no problem running it on the decsktop. This was because of security settings on the Server (Very restricted). On your desktop, make sure the security in IE is set to medium-high or below. Make sure firewall/port is opened between server and outside world.

Port 3984 - I believe this is for Java
Port 3985 - MPC
Port 3986 - MAPAdmin
Port 57005 (DEAD hex) - online Run debugger

If after trying these couple of suggestions you still have a problem, fell free to leave another message on this board and I will try to be of more help.

I normaly check the Board daily.  

RE: Cool Ice GateTool Not working from Desktop

3986 is to allow networking between Mapper systems.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close