×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Database engine on computer xxx not available

Database engine on computer xxx not available

Database engine on computer xxx not available

(OP)
Running Peachtree premium 2009 - database server has been an XP machine for the past 4-5 years, and two others (including myself) access it with Vista machines. About 10 days ago, I ran an year-end wizard since our fiscal year ended 8/31. I ran year-end on 8/25 - it ran smoothly, and I was able to access ptree with no problems on 8/26 and 27th. I then left town for 10 days, having just got back this morning - and got the error listed in subject line.

I looked for solutions online - including here - here's what I know:

* w3dbsmgr.exe is running.
* It is running as "service" per help/customer support/startup options
* I ran sas.exe - no firewalls up and running.
* Not aware of any new windows xp updates on server.

So the year end wizard could not have caused any issues, since I was able to access the system the next two days.

No new firewalls - I even shut down Norton, even though I haven't changed it since back before when everything was kosher.

The other user said he couldn't access peachtree either all of a sudden last week. He gets the same error message.

I have a few more pieces of information as I've been searching archives and wherever to find a solution. The issue has to be with server - as the two workstations that were able to connect to peachtree on the server can't anymore.

From my laptop (workstation), I pinged the server and got an acceptable response and got an IP address of the server being 204.232.162.151.

That address doesn't look right - we're using a wireless linksys server - all IP addresses used are 192.168.1.XXX.

So I went out to my status program for the linksys router - and yes, all addresses are that 192.168.etc.

So I went to server and ran IPCONFIG. Sure enough, it came back with 192.168.1.XXX as noted in status program for linksys. So where's this 204.232 IP address coming from?

w3dbsmgr.exe is running on server. It's not on my laptop. My understanding is that it should be. When I double-click on it and watch in task manager processes - it shows it fires up and then immediately closes.

I have no firewalls - I ran sas.exe - it says windows defender is present but "uncertain" whether it's running - I double-checked - its turned off.

The ppa160.ini file on my workstation does show datapath to be to z: which is the mapped drive straight into peachtree on the server as it always has been. I double checked to make sure that mapping is still correct and it is.

hosts.txt file has correct setting - 127.0.0.1

I re-installed peachtree on this workstation - didn't change a thing - still get original error message.

I'm wondering about the difference in IP addresses on server. I still can't access peachtree from workstations - even thought about doing a rollback of the server's system, but not sure if that's a good idea or not.
 

RE: Database engine on computer xxx not available

Had somethibng similar happen about a month ago also with 2009.  Difference with my stuff was that one machine could acess Peachtree and the other couldn't.  Turned out that the computer that couldn't had lost the network path.  This was in the form of x:\peachdata.  This was just a mapped drive.    

RE: Database engine on computer xxx not available

(OP)
Thanks - network path was the first thing I checked when I got this message.  

Something has to have changed on the server - my brother and I both get that same error message on our laptops - just out of the blue.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close