Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

MM 5.2 Licensing Error 3504

MM 5.2 Licensing Error 3504

MM 5.2 Licensing Error 3504

When tryihng to SAVE changes on the MSS, receive an error that says: Error - you cannot perform this operation without a valid license (3504).  The system has not been final registered - don't know if that has any impact or not.

RE: MM 5.2 Licensing Error 3504


I've think I've the same problem. I just finished the MAS configuration, and want to continue the the MSS configuration. I get an error message :failed to create postmaster subscriber postmaster : (3504 - You cannot preform this operation without a valid license.)
However I checked the Licensing at the MAS system configuration and it shows normal.

Any ideas?


RE: MM 5.2 Licensing Error 3504

Was the license imported into the VMSC or just put into the WebLM?


RE: MM 5.2 Licensing Error 3504

The Avaya MM Install files and OpenSSL have been affected by the 2038 bug. The file C:\Avaya_Support\Scripts\CreateNInstallCert.cmd has values of 10001 and 10000 that generate self-signed certificates for the MM Licensing Service and WSO to expire in 2038. Adjust these values to 9001 and 9000 so the certificates expire in 2035. Then run the recreatelicensingservice.vbs to generate and install the new Licensing Certs.

RE: MM 5.2 Licensing Error 3504

We have installed an MM 5.2 with patchs:
- MM520008
- MM520500
- MM520501
So, the MAS & MSS seem to works correctely, but during subscriber configuration from MSS web console, we receive the error "password is invalis (1023)".
The license state is normal and we have tried to run "licensing recovery tool" as described in some posts in avaya forum, without successful.
Any idea?


RE: MM 5.2 Licensing Error 3504

  It appears I am having the exact same issue. Did you find a resolution yet?

RE: MM 5.2 Licensing Error 3504

when you do the MAS host setup on MSS - ensure that the private alias has two entries separated by a space. the first one should be the FQDN of the server in its private domain then the host name.

i have found that adding both these entries allows licensing to function OK.

RE: MM 5.2 Licensing Error 3504

Yes that is there. When I run the dct file it puts it there corretly. I have read countless threads/blogs that say to take out the fqn and just have the mss name i.e. "mymss1", that hasn't worked either. I have run the license recovery tool to many times to count, no luck. Everything shows fine on the MAS, license normal. I have tried building it manually, to elminate a corruption of the dct file, no luck. After reading several entries on the Avaya User Community it appears this is a known issue but not everyone has had the same fix. What has worked for one hasn't worked for the other. I just built a system a month ago with the same software/hardware and had no issue.

RE: MM 5.2 Licensing Error 3504

I was able to finally get the install to go through. After hours on google this weekend I found someone with the same problem. Their suggestion was:
copy the file CreateNInstallCert.cmd to the directory C:\Avaya_Support\Scripts\ on MAS server (Avaya sent me this file), change the file extensión to assure that it is a batch executable. Then You only have to execute the script RecreateLicensingService.vbs located in tha same folder.

This link you can donwload the CreateNInstallCert.cmd.txt.


I downloaded this file from the above site. Removed the existing file on the MAS and loaded the new one. Install completed and MM is operational. Note: when you download the file it will have cmd.txt, you have to remove the .txt so it is just a .cmd file.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close