×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

security = share

security = share

security = share

(OP)
Hello,
Please, i need help with security mode = share.
i want to configure security = share and the parameter "username = user" in a shared folder to avoid that everybody could access to it. f I have understood correctly the manual, this configuration enables to access if the password provided matches with the user`password. But when i try to access returns this error:
    smbclient //SERVER/Docs
    Enter user's password:
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]
    Server not using user level security and no password supplied.
    tree connect failed: NT_STATUS_WRONG_PASSWORD

I also tried:
    smbclient -U user%passwd //SERVER/Docs
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]
    Server not using user level security and no password supplied.
    tree connect failed: NT_STATUS_WRONG_PASSWORD

    smbclient -U user%passwd //SERVER/Docs -P
    Failed to open /var/lib/samba/secrets.tdb
    ERROR: Unable to open secrets database

    sudo smbclient -U user%passwd //SERVER/Docs -P
    ERROR: Unable to fetch machine password for SERVER$@ in domain WORKGROUP

If i change "passdb backend = smbpasswd" in GLOBAL options:

    smbclient -U user%passwd //SERVER/Docs -P -e -A /etc/samba/smbpasswd
    ERROR: Unable to open credentials file!

    sudo smbclient -U user%passwd //SERVER/Docs -P -e -A /etc/samba/smbpasswd
    ERROR: Unable to fetch machine password for SERVER$@ in domain WORKGROUP

My config:

testparm

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]
smb: \> quit
jose@jose-laptop:~$ testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[Docs]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
    netbios name = SERVER
    server string = %h server (Samba, Ubuntu)
    map to guest = Bad User
    client lanman auth = Yes
    security = SHARE
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    unix password sync = Yes
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    dns proxy = No
    usershare allow guests = Yes
    panic action = /usr/share/samba/panic-action %d

[printers]
    comment = All Printers
    path = /var/spool/samba
    create mask = 0700
    printable = Yes
    browseable = No
    browsable = No

[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers

[Docs]
    comment = Documents
    path = /home/user/Documentos/Docs
    read only = No
    username = user

smbtree

WORKGROUP
    \\SERVER                 server (Samba, Ubuntu)
        \\SERVER\IPC$               IPC Service (server (Samba, Ubuntu))
        \\SERVER\Docs               Documents
        \\SERVER\print$             Printer Drivers

sudo pdbedit -Lw
nobody:65534:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[U          ]:LCT-00000000:
user:1000:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:CC63D87C86C99FF2FB25B31C84CF584A:[U          ]:LCT-4C23B25F:
smbguest:1001:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[U          ]:LCT-00000000:

Thanks in advance for your time
Regards

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close