×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Corrupted VM copy/import, with no obvious errors

Corrupted VM copy/import, with no obvious errors

Corrupted VM copy/import, with no obvious errors

(OP)
We copied over some VMs from an older 3.5 ESXi system, to an NFS mount for later import.   2 of them failed.  One, I rebuilt the *.vmx file and this worked.  The fourth (and most important) one fails.  All of the data are there, they are correct to the best of my ability to check.  The *.vmx file is there, the Snapshot and delta files are there.

When I go to browse the directory (use existing disk) when creating a new VM, it doesn't even recognize that there is a valid vmdk/disk in there.  Corrupted *.vmdk files?

I read several articles about using the log to reconstruct the *.vmx file (it's not corrupted to begin with).  I'm very puzzled.

Since I created 4 identical hosts, I tried importing the vmdk disk (flat) into a working config, no go.  I think because it has a Snapshot and delta that it just wouldn't work anyway.

I also tried installing the vSphere API tools for the vmware-mount command and didn't get very far.

So I'm wondering what else I might be able to do to get at the data - there is some in there we need to retrieve (database).

I know there are only 2 partitions on the image: swap and /.

I literally tried everything I could read and think of.  Creating a new system, importing the disk files, with newly-created metadata, etc.  Nothing works.

Thanks.
 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close